EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Regular File corruption

Also by EldoS: SecureBlackbox
200+ components and classes for digital security, signing, encryption and secure networking.
Posted: 06/28/2007 23:46:25
by Chris Gelhaus (Standard support level)
Joined: 04/12/2007
Posts: 20

I am regularly getting corrupted storage files. I have the SOLFSSTORAGE driver installed. When I execute GETVERSION I receive "0".

I create encrypted file (SolFSEncryption.ecAES256_SHA256) using the following code:
ivStorage.FileName = _FileName;
ivStorage.PageSize = 4096;
ivStorage.UseTransactions = false;
ivStorage.UseAccessTime = false;
ivStorage.PathSeparator = Convert.ToChar("\\");
ivStorage.Logo = _Logo; //Default Logo
ivStorage.StorageEncryption = _Encryption;
ivStorage.StoragePassword = _Password;

I then assign a drive letter (X:)
I copy a 50MB folder from my desktop, followed by an MP3 file. I can then open the X: drive, browse the folder, play the MP# through a media player.

I then close my app which uses this code:

when i try to open the file again, it will mount the drive, but I receive a message which says I've reached the end of the data.
I tried to repair the file using this command:
ivStorage.CheckAndRepair("c:\\storage1.bin",4096, 0x2, "password");

this completes, but the copied folder is gone and the MP3 is corrupt.

I really need some help figuring this out. This is a big headache.


Posted: 06/29/2007 00:27:58
by Eugene Mayevski (Team)

The developer will attempt to reproduce the issue.

Unfortunately, it will not be easy to reproduce without a test case. Please try to reproduce the above steps (i.e. file copying and reading of MP3 file) in code. This will speed-up diagnostics and fixing greatly.

Sincerely yours
Eugene Mayevski
Posted: 07/01/2007 15:28:16
by Chris Gelhaus (Standard support level)
Joined: 04/12/2007
Posts: 20

The code above is what I am using to open the dynamic storage. I use the same code for creating the file as I do for opening an existing one. The only code I didnt include would be what I do to close the file.

I first dismount the drive letter:
_Mounted = false;

then I call close:
_Initialized = false;

Does this help?
What else can I give you that would help?
Posted: 07/01/2007 16:57:37
by Chris Gelhaus (Standard support level)
Joined: 04/12/2007
Posts: 20

Here is the error.

Posted: 07/01/2007 17:48:47
by Chris Gelhaus (Standard support level)
Joined: 04/12/2007
Posts: 20

Attached are my OPEN and CLOSE functions that I have created to wrap your calls.

All I am doing is calling OPEN, then CLOSE, then OPEN again, and i get the "Reached end of file" error.

Thanks for any help!


[ Download ]
Posted: 07/02/2007 01:33:24
by Eugene Mayevski (Team)

Unfortunately so far we have not been able to reproduce the issue in our conditions. It is possible that the problem has been solved after the next public update. We plan the next update (version 1.5 beta) in a couple of days.

BTW what operating system are you testing your code on?

Sincerely yours
Eugene Mayevski
Posted: 07/02/2007 01:34:13
by Eugene Mayevski (Team)

BTW please try doing the same on the other computer. It's possible that you have some software that attempts to access the disk as soon as it appears in system.

Sincerely yours
Eugene Mayevski
Posted: 07/02/2007 07:49:15
by Chris Gelhaus (Standard support level)
Joined: 04/12/2007
Posts: 20

I am testing this on two different machine, both running Windows XP SP2. One is a member of an AD domain, the other is in a workgroup. I have a Server 2003 machine which I can try also.

This issue occurs on both machines.

Can you tell me what software attempts to access the disk when it initializes?
Posted: 07/02/2007 09:00:28
by Chris Gelhaus (Standard support level)
Joined: 04/12/2007
Posts: 20

Ok, I've made one change. I now recreate my SOLFSSTORAGE object each time i call my OPEN function. This appears to be working on one machine. But when I open the file, then try to play a .WMV file with Windows Media Player, I get an error. However, the second time I try to play the file, it works. Any ideas?
Posted: 07/02/2007 10:13:50
by Alexander Plas (Team)

Is error on the opening WMV file also "Reached the end of the file"? This error occurs on any file or on the particular file or type of files?
Also by EldoS: CallbackFilter
A component to monitor and control disk activity, track file and directory operations (create, read, write, rename etc.), alter file data, encrypt files, create virtual files.



Topic viewed 14360 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!