EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Error code 2: With SimpleMounter demo and Evaluation version

Also by EldoS: BizCrypto
Components for BizTalk® and SQL Server® Integration Services that let you securely store and transfer information in your business automation solutions.
Posted: 06/16/2015 15:33:34
by drazen (Basic support level)
Joined: 01/28/2013
Posts: 6


We have installed evaluation version of SolFS on Windows 7 x64, Delphi XE2. We have compiled simplemounter.exe and run as administrator.

First we click on "Install drivers" button and selected solfs.cab (from 18.5.2015.).

Then we click on "mount" buton and selected one existing storage file - e.g. storage.st.

At the end of this step we get error: System error code 2. The system cannot find the file specified.

Are we doing something wrong?
Posted: 06/17/2015 00:33:12
by Eugene Mayevski (Team)

Based on the described symptoms, the driver can not be found (and this is what the error code stands for). Let's check if the drivers are loaded - after you choose Install Drivers and install them, do you see the version number at the bottom of the sample's screen? If you don't see the number, this means that the driver has not been loaded. Try rebooting the system then.

Also it's important to check that no antivirus or application firewall blocks the drivers. If you have any, please disable them for the time of tests.

Sincerely yours
Eugene Mayevski
Posted: 06/17/2015 05:37:13
by drazen (Basic support level)
Joined: 01/28/2013
Posts: 6

Did the restart, disabled Avast antivirus. We are not using any other firewall.

Still the same situation.

It says: Virtual disk driver:
File System driver:
Posted: 06/17/2015 05:50:13
by drazen (Basic support level)
Joined: 01/28/2013
Posts: 6

can you try compiling the demo yourself and check it out? We have tried it on 3 different computers and it does not work. Drivers show as being installed. One of the computers does not have any antivirus installed.

If I remember correctly, demo worked fine when we tried it last year.
Posted: 06/17/2015 06:17:54
by Volodymyr Zinin (Team)

Thank you for the investigation. I will create a ticket in HelpDesk for this problem, check whether it's reproducible and write about the result there.
Posted: 09/01/2016 14:45:37
by Dennis  (Standard support level)
Joined: 09/01/2016
Posts: 1

> check whether it's reproducible and write about the result there.

What was the result?
Posted: 09/02/2016 05:27:59
by Volodymyr Zinin (Team)

The problem has been resolved. It was enough to reinstall SolFS there.
Also by EldoS: MsgConnect
Cross-platform protocol-independent communication framework for building peer-to-peer and client-server applications and middleware components.



Topic viewed 7686 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!