EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Unable to create storage

Also by EldoS: Callback File System
Create virtual file systems and disks, expose and manage remote data as if they were files on the local disk.
Posted: 06/14/2012 05:13:50
by vinoth b (Basic support level)
Joined: 06/13/2012
Posts: 9

I wanted to try out the SimpleMounter sample (using C++) provided in SFS OS edition. Because a storage file is required to try it out, I then used SFS App edition to create a storage file.

When I run the Storages sample, the StorageCreate method always returns -34. I tried using both static and debug libraries. But the result is the same.

Kindly help!
Posted: 06/14/2012 05:35:32
by Volodymyr Zinin (Team)

It seems the registration key is incorrect.
Posted: 06/14/2012 06:11:07
by vinoth b (Basic support level)
Joined: 06/13/2012
Posts: 9

The Storages sample in SFS App edition does not have any line of code asking for registration key.
Even then, I used StorageSetRegistrationKey(key) in the sample code. I have got a valid key. StorageSetRegistrationKey returns 0. But the StorageCreate method still returns error code (now 32).

Kindly help!
Posted: 06/14/2012 07:30:35
by Volodymyr Zinin (Team)

The code 32 is ERROR_SHARING_VIOLATION ("The process cannot access the file because it is being used by another process"). Check if the storage-file isn't opened by another process during the StorageCreate call.
Posted: 06/14/2012 08:18:31
by vinoth b (Basic support level)
Joined: 06/13/2012
Posts: 9

It is working now. Thanks!
Also by EldoS: CallbackRegistry
A component to monitor and control Windows registry access and create virtual registry keys.



Topic viewed 2508 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!