EldoS | Feel safer!

Software components for data protection, secure storage and transfer

SolFS for Mac

Also by EldoS: MsgConnect
Cross-platform protocol-independent communication framework for building peer-to-peer and client-server applications and middleware components.
#16986
Posted: 07/11/2011 09:17:23
by Kenny Clement (Priority Standard support level)
Joined: 09/03/2007
Posts: 61

Hi,

After using the SolFS edition for Windows (and being very happy with it),we started playing around with the Mac version.

Before SolFS, we used EncFS for encrypted virtual drives on the Mac.

Here's what we want:
An encrypted 'disk', with custom label (Logo) and icon, that can be searched with Spotlight.

So far, I managed to adjust the C code in the sample so that it mounts an encrypted drive.
However, when changing the Logo (both by passing it in StorageCreate or StorageSetLogo functions), it does not work :(
I'm assuming this is a bug?
If so, can it be fixed?
if it's not a bug, what did I do wrong?

I also didn't see a way of changing the icon of the drive yet.
It also cannot be searched by SpotLight.

I think the last 2 are default options in MacFuse, but I don't see a way of passing the MacFuse arguments. Is there a way to do this?
Stuff like allow_root, .. would be very nice.

If we can get these 2 (passing MacFuse options and Logo/icon support), we have a valid alternative for EncFS, which would be very nice.
#17001
Posted: 07/12/2011 02:53:38
by Kenny Clement (Priority Standard support level)
Joined: 09/03/2007
Posts: 61

I enabled Spotlight indexing via:
mdutil -i on /tmp/mount

and it says it's indexed.
Only.
When I use Spotlight to search for testfiles that are in there, it doesn't work.
There are never any results.

When I do 'search' in the mountpoint via the search box on the top right, no results are returned either.

So, is search/Spotlight broken? Or should I enable something?
#17003
Posted: 07/12/2011 04:12:06
by Alexander Plas (EldoS Corp.)

Hello

You can set an icon for the 'disk' with set of function StorageInstallIcon, StorageSetIcon. First function 'installs' icon file, second set icon for disk. In case of MacOS you can use full name of the icon file as icon Id.

Both storage's icon and logo should be set after storage's handle creation but before storage mounting, because FUSE allows to set their as the mounting point's parameters only.

Passing additional parameters to FUSE can be implemented as an additional flags in some existing function or as a new function.

Unfortunately I can't say anything about Spotlight problem, because I'm on vacation now. As soon as I return, I investigate the problem and I sure it will be solved.
#17004
Posted: 07/12/2011 04:15:13
by Kenny Clement (Priority Standard support level)
Joined: 09/03/2007
Posts: 61

Thanks for the quick reply, in your holiday even.
I'll try it.

Spotlight is ok for now, Logo and Icon are 'killers' for us.

I seem to remember that when i tried to set logo before StorageOpen, I got incorrect parameter.
But, I'll try it again.

Thanks again, and enjoy your holiday!
#17005
Posted: 07/12/2011 04:18:39
by Kenny Clement (Priority Standard support level)
Joined: 09/03/2007
Posts: 61

Hmmmz, I looked at it.

in the SolFS version I have, the (StoreDecl) header file doesn't contain StorageInstallIcon nor StorageSetIcon functions. :(

Also, I pass the Logo in the StorageCreate function, and that didn't work either..

You can only create the storage handle by calling StorageOpen or StorageCreate functions, right?
If so, calling it after (but before AddMountingPoint), is that too late? If so, how should I get the StorageHandle??
#17013
Posted: 07/12/2011 10:13:27
by Eugene Mayevski (EldoS Corp.)

Please check this version. It's newer than the public one. We got to make a public release, will do this when Alexander returns from vacation.


Sincerely yours
Eugene Mayevski
#17014
Posted: 07/12/2011 10:31:41
by Kenny Clement (Priority Standard support level)
Joined: 09/03/2007
Posts: 61

Thanks Eugene, I'll try it.
#17056
Posted: 07/15/2011 10:41:38
by Kenny Clement (Priority Standard support level)
Joined: 09/03/2007
Posts: 61

Hello.
I tried it.

Logo and Icons work, thanks.

One new thing I noticed (more of a nice to have for us):
Volume size (displayed in FInder) seems to be set to a fixed size of 3TB.
In EncfS (and SolFS for Windows), the size is equal to the size of the drive where the image resides.

Is that a bug? Can it be fixed?

And of course, SpotLight/search...
#17060
Posted: 07/16/2011 01:12:04
by Alexander Plas (EldoS Corp.)

Hello

I'll check volume size problem together with search/Spotlight.
Actually there is implemented same functionality as in Windows version.
#17126
Posted: 07/25/2011 10:14:27
by Kenneth Cotman (Basic support level)
Joined: 07/25/2011
Posts: 3

Hello,

I'm a collegae of Kenny and I'm working with SolFS on MacOSX Lion (10.7).
When I try to drag and drop any file to a SolFS drive, i get the following Finder error:

'The operation can't be completed because an unexpected error occurred (error code -8003).'

If i try to copy the same file to the SolFS driver (but in Terminal), the file is copied to the drive but i get and 'error' saying:

'Could not copy extended attributes to /path/file: Result too large'

Also, in Console, i get a lot of (logging?) messages, for example:

kernel: fuse_biglock_vnop_*

(* = read, write, inactive, reclaim, ...)

Any ideas to fix this? Thanks!
Also by EldoS: RawDisk
Access locked and protected files in Windows, read and write disks and partitions and more.

Reply

Statistics

Topic viewed 12263 times

Number of guests: 1, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!