EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Constant "File used by another Process" errors

Also by EldoS: MsgConnect
Cross-platform protocol-independent communication framework for building peer-to-peer and client-server applications and middleware components.
Posted: 09/30/2006 20:55:42
by Pierre duParte (Standard support level)
Joined: 09/30/2006
Posts: 1

I was using the April 2006 version which had been more or less OK. Today I updated to the latest update.

Now when I try to open the Solid File System file I get an error message that the file cannot be opened because it is used by another process, I get the error even on a reboot, i.e. when the calling application is the only one wanting to access the file.

Very frustrating....

PS Using VCL/ DelphiX (BDS)

Posted: 10/01/2006 02:28:44
by Eugene Mayevski (EldoS Corp.)

Please show the code, which is used to open the file

Sincerely yours
Eugene Mayevski
Posted: 03/15/2007 08:26:33
by mirekk36 Mirek (Basic support level)
Joined: 03/15/2007
Posts: 13

Hello Egene Mayevski,

I have the same problems sometimes when try to open some stoage files. Error code 32 and the file cannot be opened because it is used by another process.

When I restart my windows XP prof - can I open this files. U say "pleas show the code" - i'm using Your simple demo yet - SimpleMounter

so, what can be wrong?

txh for answer
Posted: 03/15/2007 11:46:37
by Eugene Mayevski (EldoS Corp.)

The original question was related to Standard edition. Your question seems to be related to driver edition. I'd suggest that you download the latest build from the site. It's build 8 (i.e. version 1.0.8). It's not yet marked on the site as such, but the file itself is fresh already. I will update version and date information right now.

Sincerely yours
Eugene Mayevski
Posted: 03/15/2007 13:15:31
by Nick Tucker (Basic support level)
Joined: 03/13/2007
Posts: 13

I just downloaded the latest version from the website,1.0.8, reinstalled the drivers and recompiled the SimpleMounter application. I created a new storage and right away get an "Out of Memory" error and from then on I also get the error message when mounting a file. Error 32, in use by another process.

Delphi 6 Enterprise / XP SP2
Posted: 03/15/2007 13:39:33
by Eugene Mayevski (EldoS Corp.)

Reverted to 1.07 until the investigation is over.

Sincerely yours
Eugene Mayevski
Posted: 03/15/2007 14:17:23
by mirekk36 Mirek (Basic support level)
Joined: 03/15/2007
Posts: 13

I can say when this problem occur - maybe investigation go faster ;) so: ...

when I normally first load driver, then mount volume, unmount volume etc all work's good but ...

... when I try mount storage before install driver - this file is catching by this "virtual" unknown process and is not accesible to next permanently restart of windows. After restart all work's fine when I load driver first before mounting


PS ofcourse i'm using driver version
Posted: 03/15/2007 14:26:57
by Eugene Mayevski (EldoS Corp.)

I've redirected both reports to the HelpDesk, so that the developer could work with them (and these reports are unlikely to be very interesting for many readers). So far we can't reproduce any of these reports, so the problem must be specific to something [to be revealed].

Sincerely yours
Eugene Mayevski
Posted: 03/16/2007 11:12:30
by mirekk36 Mirek (Basic support level)
Joined: 03/15/2007
Posts: 13

dear Eugene Mayevski,

You say:
so the problem must be specific to something

hmmmm I try describe my problem in another way:

1. I'm starting SimpleMounter
2. I'm mounting my storage file
3. I'm make "Add point" p:
.... all works good
4. I'm copying some exe file to virtual drive p:
5. I'm starting this exe file
... all works good
6. This exe file is still opened and I make "Delete point" p:
7. I make "Unmount" my storage file
...... all works good ;)
.. and now - surprise ;)

8. I try to make "Mount" my storage file and have System error code 32 etc

..... "better" information is this that when I restart my windows and normaly mound st.file and add point - on this virtual disc - this exe file have length 0 kb

I try the same TEST on another machine (PC) with fresh instalation of Windows XP Home , another procesor Intel PIV 2,6GHz - and I have really the same efect - maybe this info would be better for investigation

i'waiting for good working this component beacuse Your component SolidFile system (driver ed) is for me very good to using in my forthcoming application

best regs - mirek
Posted: 03/16/2007 11:51:11
by Eugene Mayevski (EldoS Corp.)

As I mentioned, we internally use build 1.0.8 which causes problems in certain cases. The biggest problem is that we managed to reproduce the issue once but this has gone away after full rebuild. Now we have to reproduce those problems.

Sincerely yours
Eugene Mayevski
Also by EldoS: CallbackFilter
A component to monitor and control disk activity, track file and directory operations (create, read, write, rename etc.), alter file data, encrypt files, create virtual files.



Topic viewed 12682 times

Number of guests: 10, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!