EldoS | Feel safer!

Software components for data protection, secure storage and transfer

System Error. Code: 2. The system cannot find the file specified.

Posted: 09/13/2006 03:15:31
by Eugene Mayevski (Team)

Bill Connell wrote:
I have now rebuilt the AMD PC with standard Windows XP SP2. No other software has been installed...its just the operating system. When I run the program to install the drivers it prompts to reboot. I look into the eventlog prior to rebooting the PC and I can see two entries (eventid 7000) as stated previously in this thread.

Ok, and what happened *after* reboot? Did the application work?

Sincerely yours
Eugene Mayevski
Posted: 09/13/2006 03:27:16
by Eugene Mayevski (Team)

BTW are you installing the drivers on 64-bit windows? In this case you need to install 64-bit drivers.

Sincerely yours
Eugene Mayevski
Posted: 09/13/2006 03:43:15
by Bill Connell (Basic support level)
Joined: 06/26/2006
Posts: 10

I'm not using the 64bit version of windows.

After the reboot the application does not work. When I select a solf file .st to mount, it generates the error: "System Error. Code 2. The system cannot find the file specified."

If I just key in any name at the opendialog button it generates the same error but I can see a st file has been created.

If I use solfsexplorer.exe I can open the st file that the application created. But if I try to mount it with the application again I get the 'System Error. Code 2' error again.
Posted: 09/13/2006 04:28:40
by Eugene Mayevski (Team)

great. Now the problem is more or less described. I'll pass this to support.

Sincerely yours
Eugene Mayevski
Posted: 09/13/2006 05:21:13
by Bill Connell (Basic support level)
Joined: 06/26/2006
Posts: 10

As part of the evaluation download there are two directories for the drivers.
1. Amd64
2. Win32

I have tried both sets of drivers and they both produce the same error. The application works on Intel based PC's (using the drivers in win32 dir) but on AMD processor based PC the error is produced. I have tried both set of drivers (Amd64 & Win32) as supplied in the evaluation.

Amd64 driver dir
soldisk.sys 50kb 22/08
solfs.sys 597kb 22/08

soldisk.sys 41kb 22/08
solfs.sys 511kb 22/08
Posted: 09/13/2006 05:51:16
by Bill Connell (Basic support level)
Joined: 06/26/2006
Posts: 10


Thank-you and your support team in clearing this matter up for me.

The fault was down to me not understanding what drivers to use. For windows 32bit you must use the drivers in the win32 directory - Both AMD & Intel use the same drivers. For windows 64bit you can only use the drivers in AMD64 directory.

I had initially installed the AMD64 drivers on a AMD windows 32bit platform. When it didn't work I uninstalled the drivers and tried to install the 32bit drivers instead, but the uninstalldriver function was not removing the driver files.

I manually removed the files and any registry entries and rebooted the PC and used the installdrivers function but pointing to the 32bit drivers.

The result was a working program.

Thanks Eugene and the team for your patience and insight.

Many thanks




Topic viewed 24975 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!