EldoS | Feel safer!

Software components for data protection, secure storage and transfer

error code 75777 received when initiating TLS

Also by EldoS: BizCrypto
Components for BizTalk® and SQL Server® Integration Services that let you securely store and transfer information in your business automation solutions.
Posted: 04/22/2015 13:34:42
by Leonardo Herrera (Standard support level)
Joined: 02/14/2011
Posts: 66

Oh, thanks. I don't have any problem for Gmail, except that I just have to leave smImplicit, and for Outlook.com (live.com) it has to be smExplicit. Other than that everything works as expected.

Kind regards,
Leonardo Herrera
Posted: 04/22/2015 14:34:39
by Eugene Mayevski (EldoS Corp.)

It is very strange if different services use Implicit and Explicit on the same port. GMail SSL works on port 465/Implicit .

Sincerely yours
Eugene Mayevski
Posted: 04/24/2015 13:59:10
by Leonardo Herrera (Standard support level)
Joined: 02/14/2011
Posts: 66


Yes, you are right it is strange. live.com also uses StartTLS on port 25.
Posted: 04/24/2015 15:17:42
by Eugene Mayevski (EldoS Corp.)

Leonardo Herrera wrote:
live.com also uses StartTLS on port 25.

That is ok. Explicit TLS on port 25 as well as on port 587 is normal. Implicit TLS on port 465 is correct as well. Other combinations are confusing but I guess the only thing you can do is let the user choose the mode.

I've added a task for autodetecting implicit TLS for protocols where this is technically possible. It will go to SecureBlackbox 14, probably.

Sincerely yours
Eugene Mayevski



Topic viewed 4338 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!