EldoS | Feel safer!

Software components for data protection, secure storage and transfer

local Port Forwarding session doesn't close properly

Also by EldoS: Solid File System
A virtual file system that offers a feature-rich storage for application documents and data with built-in compression and encryption.
#5053
Posted: 02/18/2008 10:55:37
by joshua chen (Basic support level)
Joined: 02/16/2008
Posts: 3

Hi,
SSB version 5.2, C# 2005 edition.
I am using SSHServer and localPortForwarding samples. I started the SSH connection to SSHServer successfully. But when I stop the SSH connection from localportforwarding side, SSHServer still have SSH session instance opened. It only closes the SSH session after the idle timeout. I saw the TELSSHClient does call the Close() method. But SSHServer does not close the SSH session. The "keep alive if no active" flag is false. Is there any method in the client side needs to be called?

It is very easy to reproduce it. Connect to SHHServer using localPortFrwarding client and SSHServer shows successful connection. Then click the "Stop" button in the client, SSHServer doesn't display any disconnect log message. If try to setup a connection again. SSHServer will say: Connection accepted. Active connectins 2 from 20.

I would like to know if there is any event that SSH Server will recieve upon closing of TELSSHClient?

Thanks,

Joshua
#5054
Posted: 02/18/2008 11:38:56
by Ken Ivanov (EldoS Corp.)

Actually, it's a lack of the demo who does not check socket connection for graceful disconnect. If m_Socket.Poll() call returns true, and then m_Socket.Receive() call returns 0, socket connection should be considered gracefully closed. However, this situation is not handled in the demo, leading to the issue you have reported.

Reply

Statistics

Topic viewed 1353 times

Number of guests: 1, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!