EldoS | Feel safer!

Software components for data protection, secure storage and transfer

TElXMLSigner canonicalisation inc-exc

Also by EldoS: CallbackRegistry
A component to monitor and control Windows registry access and create virtual registry keys.
#5203
Posted: 02/29/2008 03:25:22
by Cees Lieshout (Standard support level)
Joined: 02/06/2008
Posts: 10

I've tried the new release and it works. When canocalising the signinfo, the namespace is included in the signinfo and the sign verifies in oXygen.

Thanks for the support.
#5205
Posted: 02/29/2008 04:52:35
by Cees Lieshout (Standard support level)
Joined: 02/06/2008
Posts: 10

In my testing spree i'm using a SHA1 component to calculate the digestvalues of different xml-nodes. Earlier i tried the eldos (internal?) function, but it returned the wrong value. However switching back to "SecureBlackbox - version 4.1.71", it gives the correct value.
Has the (internal) function a different interface? I also noticed the help .finish:bytearray, but the implementation seems the be string.

Code
h : TElHashFunction;
...
s := 'abc';
h := TElHashFunction.create(SB_ALGORITHM_DGST_SHA1);
h.Update(@s[1], length(s) );
r := h.Finish;


gives r in hex 13C8650BE7C679EF10090D5DB17698D31DF56B7C
should be: A9993E364706816ABA3E25717850C26C9CD0D89D ( the result from the 4.1 version and known selftest).

The digest calculated in the xml sign is correct.

#5207
Posted: 02/29/2008 05:26:58
by Eugene Mayevski (EldoS Corp.)

If you are using the evaluation version, the keys are different for each version. Incorrect license key will lead to invalid calculation results. This is intentional behavior.


Sincerely yours
Eugene Mayevski
#5210
Posted: 02/29/2008 05:33:07
by Dmytro Bogatskyy (EldoS Corp.)

Strange.
The same code under SecureBlackbox v6.0.134
...
r := BeautifyBinaryString(BinaryToString(h.Finish), ' ')
returns the correct value: A9...
Maybe the problem in function that are you using to convert to a hex value?
#5212
Posted: 02/29/2008 05:44:01
by Cees Lieshout (Standard support level)
Joined: 02/06/2008
Posts: 10

Tried it in a testapp, i didnt't initialize the SetLicenseKey. I didn't expect the result to be incorrect, earlier i got an exception that uninitialised some functions didn't work, so it didn't cross my mind.

But it works correctly now, i can discard the other component-set and use the eldos function.

Thanks
#5215
Posted: 02/29/2008 06:35:08
by Eugene Mayevski (EldoS Corp.)

Yes, the exception will be raised in high-level components. Checking the key in low-level math functions would slow down processing of the data.


Sincerely yours
Eugene Mayevski
Also by EldoS: CallbackDisk
Create virtual disks backed by memory or custom location, expose disk images as disks and more.

Reply

Statistics

Topic viewed 5680 times

Number of guests: 2, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!