EldoS | Feel safer!

Software components for data protection, secure storage and transfer

PHP make error

Also by EldoS: Rethync
The cross-platform framework that simplifies synchronizing data between mobile and desktop applications and servers and cloud storages
Posted: 07/28/2016 06:23:52
by stelio pizzolatto (Premium support level)
Joined: 12/04/2015
Posts: 20

Using secbboxphp_linux_x64.tar.gz Version 15.0.294. Released on 26 June 2016.

output from phpize

root@HAL9000:/var/www/eldos/ExtensionSources/sbb# phpize
Configuring for:
PHP Api Version: 20121113
Zend Module Api No: 20121212
Zend Extension Api No: 220121212

Running root@HAL9000:/var/www/eldos/ExtensionSources/sbb# ./configure --with-sbb=/var/www/eldos/Libraries/Linux64

Results are fine so far

Running make
root@HAL9000:/var/www/eldos/ExtensionSources/sbb# make

/usr/local/include/php/Zend/zend_API.h:608:18: error: lvalue required as unary ‘&’ operand
zval_ptr_dtor(&zv); \
First error

From now one there is e succession of errors
Last ones are

/usr/local/include/php/Zend/zend_API.h:625:38: note: in expansion of macro ‘ZVAL_ZVAL’
#define RETVAL_ZVAL(zv, copy, dtor) ZVAL_ZVAL(return_value, zv, copy, dtor)
/var/www/eldos/ExtensionSources/sbb/code/sbasn1.c:393:4: note: in expansion of macro ‘RETVAL_ZVAL’
RETVAL_ZVAL((zval *)pDataOutResult, 1, 0);
make: ** [code] Erro 1

Any help on this one??
Best regards
Posted: 07/28/2016 07:32:29
by Eugene Mayevski (EldoS Corp.)

Could you please check via phpinfo() function in PHP, what version of PHP engine and of Zend Framework you have? It looks like your version is either too new or too old.

Sincerely yours
Eugene Mayevski
Posted: 07/28/2016 10:49:42
by stelio pizzolatto (Premium support level)
Joined: 12/04/2015
Posts: 20

PHP Version 5.5.9-1ubuntu4.14

No Zend engine at all

Thinks PHP dropped using Zend as default part of it's package
Posted: 07/28/2016 11:32:50
by Eugene Mayevski (EldoS Corp.)

Hmm, we build pre-compiled modules (although on Windows) for every supported version of PHP, and we didn't observe this behavior. The person who created the PHP generator will be available only in a week, and he'll be able to try to reproduce the issue on his side, and make the changes if necessary.

On a side note you have quoted Zend API version number, which implies that Zend is present on your system. And also zend files are referenced and accessed by the compiler.

Sincerely yours
Eugene Mayevski
Posted: 07/28/2016 12:17:20
by Eugene Mayevski (EldoS Corp.)

I have downloaded (updated) PHP 5.6 into Ubuntu 15.10 . Then I've successfully built the extension with PHP 5.6.

I can imagine that PHP developers have introduced some breaking change (unintentionally of course) into version 5.5, and, as this is not the latest version (and even not the second latest), there was not enough testing to detect this change and find it breaking.

Unfortunately in this situation there's not much one could do besides upgrading to something more recent. Note, that PHP 7 is probably not a good candidate for a working site due to the number of breaking changes in it. SecureBlackbox 15 will support PHP 7 in the upcoming build or in the build next to the upcoming.

Sincerely yours
Eugene Mayevski
Posted: 07/28/2016 14:20:47
by stelio pizzolatto (Premium support level)
Joined: 12/04/2015
Posts: 20


Will upgrade my PHP to 5.6 and let us see what happens

Posted: 07/28/2016 17:55:11
by stelio pizzolatto (Premium support level)
Joined: 12/04/2015
Posts: 20

Now running PHP 5.6 with Zend engine as shown:
PHP Version 5.6.24-1+deb.sury.org~trusty+1
PHP API 20131106
PHP Extension 20131226
Zend Extension 220131226
Zend Extension Build API220131226,NTS
PHP Extension Build API20131226,NT

This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.6.0, Copyright © 1998-2016 Zend Technologies
with Zend OPcache v7.0.6-dev, Copyright © 1999-2016, by Zend Technologie

file attached contains output from commands used to building extension using phpize utility

Really need some help on this one

[ Download ]
Posted: 07/28/2016 18:41:22
by Eugene Mayevski (EldoS Corp.)

Have you also updated/installed php-dev package with apt-get? So far it looks like you have older version of source files, and they don't have with PHP itself.

Sincerely yours
Eugene Mayevski
Posted: 08/01/2016 15:31:13
by stelio pizzolatto (Premium support level)
Joined: 12/04/2015
Posts: 20

commands that I used to upgrade PHP
sudo add-apt-repository ppa:ondrej/php5-5.6
sudo apt-get update
sudo apt-get install php5
service apache2 stop
service apache2 start

But as said in redme.txt :
Building extension using phpize utility (if you installed PHP as a binary):

seams I would not need PHP source files.

Am'i wrong on this one?
Posted: 08/03/2016 12:47:42
by Eugene Mayevski (EldoS Corp.)

To answer your latest question -- you need phpize, which comes with php-dev package. and you need it to be of the same version that PHP itself.

Sincerely yours
Eugene Mayevski
Also by EldoS: CallbackProcess
A component to control process creation and termination in Windows and .NET applications.



Topic viewed 1021 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!