EldoS | Feel safer!

Software components for data protection, secure storage and transfer

SiimpleSFTPClient wont work but SimpleSSHClient will

Posted: 06/09/2016 14:58:17
by Michael Lovett (Standard support level)
Joined: 03/20/2013
Posts: 28

Hi there, I have version of SBB, and I have an app that has been using SimpleSFTPClient and SimpleSSHClient to connect to SSH servers that I built a few years ago, and they have been working fine.

I'm now attempting to use my same application to connect to newer servers that would be running a newer version of OpenSSH.

My application is able to connect via the SimpleSSHClient, but I'm getting error 10058 when attempting to connect using the SimpleSFTPClient, and I can't figure out why. I wonder if it has to do with the newer SSH on the server I'm using? (The sshd_config files are the same on the old ssh server and the new one).

I tried running the ssh server in debug mode, and here are a few lines around the connection attempt. "soco2" is the username.

debug1: userauth-request for user soco2 service ssh-connection method none [preauth]
debug1: attempt 0 failures 0 [preauth]
debug1: PAM: initializing for "soco2"
debug1: PAM: setting PAM_RHOST to "sp3"
debug1: PAM: setting PAM_TTY to "ssh"
Connection closed by [preauth] <<------

Note the last line; for some reason the client (SimpleSFTPClient) is closing the connection pretty early in the connection process.

Note that I can use scp from the command line to put/get files to this newest server, using the same user and keys as my code is supplying to the SimpleSFTPClient.

Any ideas of how I might go about debugging this further?

Posted: 06/10/2016 00:49:02
by Eugene Mayevski (Team)

Please run SimpleSFTP sample in {SecureBlackbox}\Samples\{language}\Client\Desktop directory . It creates a brief log of the connection, which will tell us more about what's happening.

On a side note, SSH connectivity is a running target and we add changes and updates to it all the time, so that the SSH client could connect to the recent server versions.

Sincerely yours
Eugene Mayevski
Posted: 06/13/2016 13:24:46
by Michael Lovett (Standard support level)
Joined: 03/20/2013
Posts: 28

Thanks for the reply.

Before I got your reply I had already downloaded and tried the 14.x version of the library and I was able to connect SFTP with it.

So at this point we've purchased the new library and are going to use it without learning exactly why the old black box was having trouble with the new server.




Topic viewed 571 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!