EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Problem after installing last version

Also by EldoS: CallbackDisk
Create virtual disks backed by memory or custom location, expose disk images as disks and more.
#36656
Posted: 05/05/2016 18:11:05
by Eduardo Helminsky (Standard support level)
Joined: 08/20/2010
Posts: 102

Hi

After installing the last version of SecBlackBox 14.292 some of my customers start to receive an error. So far I do not have a xml file to send to you but the message is:
"XML Parser error at position 2440 (0x988): TElXMLDomEntityReference: entity name expected".

This process of signing XML were running OK and it is used a lot of times. I am going to try to get the XML that produces the error.

Thanks in advance
#36662
Posted: 05/06/2016 05:06:29
by Dmytro Bogatskyy (EldoS Corp.)

Thank you for contacting us,

Quote
"XML Parser error at position 2440 (0x988): TElXMLDomEntityReference: entity name expected".

This error means that your XML document is not well-formed. That '&' (ampersand) character is not followed by the name of an entity or '&' (ampersand) character wasn't escaped correctly by xml writer if it appears in the text.
Quote
After installing the last version of SecBlackBox 14.292

From which version you have updated? As far as I remember, in minor versions there was no changes related to the XML parser.
#36668
Posted: 05/06/2016 12:05:33
by Eduardo Helminsky (Standard support level)
Joined: 08/20/2010
Posts: 102

Dmytro Bogatskyy

It was my fault (again) but thanks to your contribution. Indeed the problem was with XML file not well-formed. There was an (&) alone and it should be &

Eduardo

Reply

Statistics

Topic viewed 1181 times

Number of guests: 1, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!