EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Special chars like á, ñ, etc are not shown in signed PDF

Also by EldoS: Rethync
The cross-platform framework that simplifies synchronizing data between mobile and desktop applications and servers and cloud storages
Posted: 01/04/2016 11:47:18
by Martin ANDRES (Standard support level)
Joined: 09/25/2014
Posts: 18

I'm signing a PDF with Sig.WidgetProps.CustomText.Add('Állategészségügyi', 58, 31, 10) but the special chars like Á, é and ü are no shown in the signature, only a blank space is displayed. I attach a screen capture of the resulting PDF where you can see the text Állategészségügyi is not correctly displayed.

I'm using the component in Delphi.

What should I do to manage chars like á in PDFs signatures?

I really appreciate your help.


Posted: 01/04/2016 11:50:07
by Eugene Mayevski (EldoS Corp.)

Please see this how-to article: https://www.eldos.com/documentation/sb...icode.html

Also the following Forum topic will help you:

Sincerely yours
Eugene Mayevski
Posted: 01/04/2016 11:53:53
by Dmytro Bogatskyy (EldoS Corp.)

Thank you for contacting us,

If you wish to use non-ASCII characters, then please refer to "Widget font and encoding" option in the PDFBlackbox\Destkop\Signer or SecurePDF samples. (Choose: 'Free Serif, Unicode' or 'Helvetica, Win-1252', or 'Helvetica, Auto Encoding' option).

P.S. In version 13 we have significantly improved support for non-ascii characters in a signature widget when auto encoding option is used, so upgrading to newer version may solve a problem without any code.
Posted: 01/05/2016 07:31:21
by Martin ANDRES (Standard support level)
Joined: 09/25/2014
Posts: 18

Thanks Eugene and Dmytro!!!

I've used the example from PDFBlackbox\Destkop\Signer and it worked :-)

Thanks and regards,



Topic viewed 1521 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!