EldoS | Feel safer!

Software components for data protection, secure storage and transfer

unable to run XMLBlackbox correctly

Also by EldoS: Rethync
The cross-platform framework that simplifies synchronizing data between mobile and desktop applications and servers and cloud storages
#35176
Posted: 12/04/2015 15:56:51
by stelio pizzolatto (Premium support level)
Joined: 12/04/2015
Posts: 28

Configurations
Apache Version Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.13
Apache API Version 20120211

PHP Version 5.5.9-1ubuntu4.13

Lines at php.ini:

extension=libsbbphp.so
sbb.license_key=2DA6...6D64

file downloaded:
secbboxphp_linux_x64.tar.gz

library libsbbphp.so at:
/usr/lib/php5/20121212/

apache2 start-up error.log :
PHP Warning: PHP Startup: Invalid library (maybe not a PHP library) 'libsbbphp.so' in Unknown on line 0

No other error message whatsoever
No info about SecureBlackbox components in phpinfo()at all

Best regards
#35177
Posted: 12/04/2015 16:12:44
by Dmytro Bogatskyy (EldoS Corp.)

Thank you for contacting us,

Please check the README file that comes with archive.
Quote
extension=libsbbphp.so
PHP Warning: PHP Startup: Invalid library (maybe not a PHP library) 'libsbbphp.so' in Unknown on line 0

'libsbbphp.so' is not the php extension file, it is the dynamic library that used by extension. The extension should be compiled from sources for your php version.

Reply

Statistics

Topic viewed 1050 times

Number of guests: 1, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!