EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Can compile a package but not build it

Also by EldoS: Solid File System
A virtual file system that offers a feature-rich storage for application documents and data with built-in compression and encryption.
Posted: 11/10/2015 04:38:05
by Maurizio Ferreira (Standard support level)
Joined: 04/29/2010
Posts: 6

I've developed a program using the SbIdSftp component.
The application is built as a main program plus several other packages.
All are built using the "link with runtime packages" option.

The application and the packages are all referenced by a single project group,
so that I can easily compile/build all with a single click.

The component in question is used by a single package, referencing it in
the uses clause :


if I compile the project group, it all works as expected,
however if I attempt to build it , I receive an error, and the compilation of subsequent packages gets interrupted.
This is rather annoying, since then I must manually rebuild all the other packages.

[dcc32 Fatal Error] SwwScComunic.pas(15): E2411 Unit SBIdSFTP in package IdSFTPIndy10D22 refers to unit SBSSHKeyStorage which is not found in any package. Packaged units must refer only to packaged units

What can I do to overcome the problem ?

Best regards
Posted: 11/10/2015 04:42:24
by Eugene Mayevski (EldoS Corp.)

How do you deal with SecureBlackbox units - have you put them to some package or you used SecureBlackbox package or ... ?

Sincerely yours
Eugene Mayevski
Posted: 11/10/2015 09:59:12
by Maurizio Ferreira (Standard support level)
Joined: 04/29/2010
Posts: 6

I've dezipped the sources in

then I've added the following paths to the Delphi library path :


and then I've opened the groupproject :


I've removed the pgp project from the group, and I've compiled (or builded ?) the project group

after that, I've added the unit to the uses clause of a unit of my package.

The component is not placed on any form, since is is created dynamically by my application, with the following instruction:

Ftp := TElIdSFTPClient.Create(nil);

after that, I can compile my package, but not build it.

Best regards
Posted: 11/10/2015 10:43:33
by Eugene Mayevski (EldoS Corp.)

If you are building your project with packages, I suggest that you move all used SecureBlackbox files to a package and compile it, then add it to your project. This should solve your problem.

Sincerely yours
Eugene Mayevski
Posted: 11/10/2015 11:07:10
by Maurizio Ferreira (Standard support level)
Joined: 04/29/2010
Posts: 6

Your suggestion solved the problem.

Since I already have the needed package (a package of mine) , I removed from it the "require" clauses to the Eldos packages, (it needs only the SbIdFtp unit) and now it works perfectly.

Best regards
Also by EldoS: CallbackFilter
A component to monitor and control disk activity, track file and directory operations (create, read, write, rename etc.), alter file data, encrypt files, create virtual files.



Topic viewed 2398 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!