EldoS | Feel safer!

Software components for data protection, secure storage and transfer

What have you changed?

Also by EldoS: RawDisk
Access locked and protected files in Windows, read and write disks and partitions and more.
#34599
Posted: 10/05/2015 08:10:40
by Walter Schrabmair (Priority Standard support level)
Joined: 05/03/2013
Posts: 150

Hi,
I just wanted to run a finished prg with the latest SBB in Delphi XE6 and all my https (GET) does not work anymore. I get always connection broken.
I also cheched it with the demo and the demo works fine (Httpsclient.get)
I also copied the HTTPSCLIENT component form the demo sheet to my sheet and still it does not work. Recently I added the demo into my project for one GET request and that works. But I can not change all my code for that. I also tried only SSL2 SSL3 and TLS1 and still no success. In the old SSB it worked fine. on URL is https://www.carlroth.com/en/en
Please tell me what to do.
thanks
#34600
Posted: 10/05/2015 08:13:47
by Vsevolod Ievgiienko (EldoS Corp.)

Hello.

Could you please clarify what exact SecureBlackbox version works for you and what version doesn't work.
#34602
Posted: 10/05/2015 09:16:46
by Walter Schrabmair (Priority Standard support level)
Joined: 05/03/2013
Posts: 150

The latest SBB does not work with my HTTPSCLIENTs.get (13.0.280)
And it worked fine with Version 12.0.260 (I think. I have reinstalled the latest and do now not know what version it was.)
The strange is that the DEMO in 13.0.280 works fine.
But I have a lot of code in the event handlers of my old httpsclients. So I can not easily use the embedded DEMO code for all httpclients.

It would be great from you, if you could specify what to change in the properties. I have compared all the prop. and did adapted it of course. but no success. The event handler I did not change.
#34603
Posted: 10/05/2015 09:21:43
by Vsevolod Ievgiienko (EldoS Corp.)

All changes between the 12th and the 13th version are listed in changes.txt. Could you clarify what do you mean by "does not work". Do you get any exception or error? Exception call stack will also help.
#34604
Posted: 10/05/2015 09:31:46
by Walter Schrabmair (Priority Standard support level)
Joined: 05/03/2013
Posts: 150

At all https I get:
Connection failed do to error (75784)
#34605
Posted: 10/05/2015 09:33:25
by Walter Schrabmair (Priority Standard support level)
Joined: 05/03/2013
Posts: 150

And when I continue then I get: Connection lost (err code is 100353)
#34606
Posted: 10/05/2015 09:38:36
by Vsevolod Ievgiienko (EldoS Corp.)

75784 stands for ERROR_SSL_BAD_CERTIFICATE. This means that TElX509CertificateValidator fails to validate server certificate. Its hard to say why this happens without debugging.

I recomment you to check TElX509CertificateValidator.InternalLogger.Log list for detailed log of validation. You can also post this log here for investigation.
#34607
Posted: 10/05/2015 09:43:17
by Walter Schrabmair (Priority Standard support level)
Joined: 05/03/2013
Posts: 150

I found my error. Sorry for bother you.
I had in the ValidateCertificate Event a wrong client.
Thanks For help
Best
#34608
Posted: 10/05/2015 09:44:12
by Walter Schrabmair (Priority Standard support level)
Joined: 05/03/2013
Posts: 150

Thanks a lot for your help, with this info I could check the routine for the SSL Cert.

Thanks
Walter
Also by EldoS: MsgConnect
Cross-platform protocol-independent communication framework for building peer-to-peer and client-server applications and middleware components.

Reply

Statistics

Topic viewed 2875 times

Number of guests: 1, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!