EldoS | Feel safer!

Software components for data protection, secure storage and transfer

SocketTimeout not working

Posted: 06/14/2015 23:47:48
by Alain  (Basic support level)
Joined: 04/22/2015
Posts: 14

I used this code to timeout if the url provided is wrong. but it doesn't time out.

client = new TElWebDAVClient();

                httpClient.PreferKeepAlive = true;
                httpClient.UseSSLSessionResumption = true;

                httpClient.RequestParameters.Username = _userName;
                httpClient.RequestParameters.Password = _password;
                httpClient.OnCertificateValidate += new TSBCertificateValidateEvent(httpClient_OnCertificateValidate);
                httpClient.SocketTimeout = 60000;

                client.Owner = "https://eldos.com";
                client.HTTPSWebDAVClient = httpClient;
                client.IncludeBackLinks = false;

this is the part where it hangs.

client.BaseURL = _url;
                _RootFolder = _url;

                TElWebDavObjectList objs = new TElWebDavObjectList();
Posted: 06/15/2015 00:47:24
by Eugene Mayevski (Team)

SocketTimeout does what it is expected to do - it closes connection if there's no inbound activity on the socket for the specified time. You should be observing some different issue.

Did you try the same on the sample we provide with SecureBlackbox? If no, it would be great if you tried and let us know if the problem is reproducible with it. This will give us the ground for further investigation.

Sincerely yours
Eugene Mayevski
Posted: 06/15/2015 01:13:57
by Alain  (Basic support level)
Joined: 04/22/2015
Posts: 14

I tried this with the sample code of WebDavdisk. it hangs indefinitely.
Posted: 06/15/2015 01:21:00
by Eugene Mayevski (Team)

Thank you for the clarification. We will try to check the issue today.

Sincerely yours
Eugene Mayevski
Posted: 06/16/2015 01:36:05
by Alexander Ionov (Team)

Unfortunately we're unable to reproduce the issue with our WebDavClient sample. If I click the very left button in its main window, then enter "https://eldos.com" as "Base URL" value and click "OK", I get an exception saying "Invalid response XML structure".

Could you please create a very simple application that reproduces the issue? In this case we would have all the components configured the same way as you do, and as such, could run the app and see what's going wrong.

Thank you.

Best regards,
Alexander Ionov
Posted: 06/18/2015 21:41:50
by Alain  (Basic support level)
Joined: 04/22/2015
Posts: 14

my example URL is http://sample.dav.com/remote.php/webdav, when I use this and set a SocketTimeOut it works.

but if i modify the url to http://sample.dav.com2/remote.php/webdav it hangs indefinitely.
Posted: 06/19/2015 00:31:23
by Eugene Mayevski (Team)

This makes a big difference. Host name resolution is not controlled by the socket timeout, but the socket layer should return the error in case of the invalid host name. If it attempts to resolve the address, this can be an issue in the socket layer (of the OS, not of SecureBlackbox). We will try to check the problem.

Let's continue in HelpDesk ( https://www.eldos.com/helpdesk/ ) please. I have created a new support ticket based on your above message. You will see your (and only your) support tickets by following this URL. You will also get e-mail notifications about updates related to your support ticket.

Sincerely yours
Eugene Mayevski
Posted: 12/23/2015 04:02:48
by Andrew Vin (Basic support level)
Joined: 12/23/2015
Posts: 1

Seems we have simular issue. Is it resolved/confirmed?

Our client use SFTP server through TElSimpleSFTPClientEx.
It works ok for some time, but then it hangs and SocketTimeout doesn't work.
Posted: 12/23/2015 05:30:07
by Ken Ivanov (Team)

Hi Andrew,

Thank you for getting in touch with us.

As your question refers to a different component/issue, I've created a new topic for it where I encourage you to continue the discussion.




Topic viewed 3290 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!