EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Calling TElMessagePart.GetText destroys data

Also by EldoS: MsgConnect
Cross-platform protocol-independent communication framework for building peer-to-peer and client-server applications and middleware components.
#3162
Posted: 06/17/2007 03:24:01
by Ram Cohen (Standard support level)
Joined: 06/28/2006
Posts: 26

If loading a MIME message by using the SBMIME.Unit.mpoDelayDataDecode flag then calling TElMessagePart.GetText once is OK but subsequent calls returns a garbage string.
Problem does not happen if not using the delay decode option.
#22088
Posted: 10/19/2012 04:12:03
by Niklas Kjellander (Standard support level)
Joined: 09/30/2008
Posts: 49

What is the status of this topic, I came to the same conclusion, that GetText destroys the data. My scenario is a bit different though. Instead of loading message I'm creating it.

Code
string text = string.Empty;
TElPlainTextPart textPart = new TElPlainTextPart();
textPart.SetText("some text");
int result = textPart.GetText(ref text);


Why is the data destroyed after reading it?

Best regards,

Niklas Kjellander
#22090
Posted: 10/19/2012 04:18:46
by Eugene Mayevski (EldoS Corp.)

Moved to HelpDesk.


Sincerely yours
Eugene Mayevski

Reply

Statistics

Topic viewed 1523 times

Number of guests: 1, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!