EldoS | Feel safer!

Software components for data protection, secure storage and transfer

TElSimpleFTPSClient - 425 error

Also by EldoS: RawDisk
Access locked and protected files in Windows, read and write disks and partitions and more.
#33274
Posted: 05/08/2015 10:44:25
by Christian Thompson (Basic support level)
Joined: 05/08/2015
Posts: 2

Hi, I am running into a 425 error when trying to list a directory using the TEISimpleFTPSClient. I generated this log using a slightly customized version of your sample console application:

=======================================================

2015-05-08T11:15:38 Command: AUTH TLS
2015-05-08T11:15:38 Receive: 234 AUTH TLS successful

2015-05-08T11:15:38 Command: USER ****
2015-05-08T11:15:38 Receive: 331 Password required for ****

2015-05-08T11:15:38 Command: PASS ****
2015-05-08T11:15:38 Receive: 230 User **** logged in

2015-05-08T11:15:38 Command: PBSZ 0
2015-05-08T11:15:39 Receive: 200 PBSZ 0 successful

2015-05-08T11:15:39 Command: PROT P
2015-05-08T11:15:39 Receive: 200 Protection set to Private

2015-05-08T11:15:39 Command: FEAT
2015-05-08T11:15:39 Receive: 211-Features:
MDTM
MFMT
TVFS
AUTH TLS
MFF modify;UNIX.group;UNIX.mode;
MLST modify*;perm*;size*;type*;unique*;UNIX.group*;UNIX.mode*;UNIX.owner*;
PBSZ
PROT
REST STREAM
SIZE
211 End

2015-05-08T11:15:47 Command: TYPE A
2015-05-08T11:15:48 Receive: 200 Type set to A

2015-05-08T11:15:48 Command: PASV
2015-05-08T11:15:48 Receive: 227 Entering Passive Mode (xxx).

2015-05-08T11:15:48 Command: MLSD
2015-05-08T11:15:49 Receive: 150 Opening ASCII mode data connection for MLSD

2015-05-08T11:15:49 Receive: 425 Unable to build data connection: Operation not permitted

2015-05-08T11:15:51 Command: QUIT
2015-05-08T11:15:51 Receive: 221 Goodbye.

=======================================================

This log is almost identical to what FileZilla generates but FileZilla successfully gets the directory listing. The only difference I can see is that FileZilla uses "TYPE I". I tried explicitly setting Client.TransferType to 1, but the client still used "TYPE A".

Looking around on the internet I found that this error might be that the client isn't reusing the SSL session. If this is the case, is there any way to force it to do so?

Thanks,
Christian
#33277
Posted: 05/08/2015 11:30:00
by Christian Thompson (Basic support level)
Joined: 05/08/2015
Posts: 2

Found it: client.UseSSLSessionResumption
#33279
Posted: 05/09/2015 09:35:37
by Eugene Mayevski (EldoS Corp.)

Thank you for contacting us.

The error can have many reasons, from the options that need to be adjusted to network firewall blocking the connection. Binary vs ASCII type should not matter in this case (as per RFC 3659 section 7.2).

It's not clear if your problem is solved by using UseSSLSessionResumption or not. Please let us know.


Sincerely yours
Eugene Mayevski

Reply

Statistics

Topic viewed 713 times

Number of guests: 1, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!