EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Problem with SSH password authentication

Posted: 05/16/2006 05:12:24
by Andrew Filby (Premium support level)
Joined: 05/16/2006
Posts: 3

We are currently evaluating the latest Secure Black Box package for use within our .Net 2.0 product, we are using the SSHClient object with the SFTPClient object.

We are testing using the .Net library against a Linux machine using OpenSSH server.

We can establish a connection if we use the public key authentication method, but if we use password authentication only (not interactive) we always get an error 114 in the OnError callback.

We get exactly the same problem if we use the sample SFTP client application to connect using just user name and password.

A user name/password connection to the Linux OpenSSH server using the OpenSSH SFTP client works, as does a Putty connection.

Any help would be appreciated.
Posted: 05/16/2006 06:10:24
by Eugene Mayevski (Team)

Probably your server uses keyboard-interactive authentication. The latest builds of SecureBlackbox include this method of authentication in all SSH and SFTP samples.

Sincerely yours
Eugene Mayevski
Posted: 07/14/2006 09:57:51
by Bill Armstrong (Basic support level)
Joined: 07/14/2006
Posts: 22

I'm experiencing the exact same problem, but with the ActiveX version of SecureBlackBox. I am connecting to a Linux box running OpenSSH. I have been able to successfully connect with password authentication using another library that I am evaluating, but that library is a managed library and I want to avoid mixing managed and unmanaged code if possible. I've tried connecting with a couple of your samples and I get the same error in every one "Error 114".
Posted: 07/14/2006 10:08:27
by Ken Ivanov (Team)

Please consider enabling keyboard-interactive authentication and check if it helps. The latest build of SecureBlackbox includes several samples which support keyboard-interactive authentication (e.g., SimpleSFTPDemo).
Posted: 07/14/2006 10:27:48
by Bill Armstrong (Basic support level)
Joined: 07/14/2006
Posts: 22

Several comments:

1. Maybe the retail version has this option in the samples, but the evaluation version does not (screen capture provided).
2. That being said, I had already modified the source code to try the keyboard-interactive authentication option and got the same error.
3. As I said in my previous post I've been able to connect with password authentication with another SSH client library, so I know that it is supported and enabled on the server side.
4. I am writing a Windows Service application, not a terminal program. Even if keyboard-interactive authentication did work, it would be of no use to me.

[ Download ]
Posted: 07/14/2006 11:06:11
by Bill Armstrong (Basic support level)
Joined: 07/14/2006
Posts: 22

FYI, I just tried connecting to a Solaris 9 box and was able to connect using Password authentication without any problems.

It would seem that you have a problem connecting to OpenSSH on Linux boxes using Password authentication. My Linux box is running SUSE Linux 10.1 (the latest released version).
Posted: 07/14/2006 13:23:59
by Eugene Mayevski (Team)

What version of OpenSSH does it run?
We use OpenSSH ourselves and have no problems with it.

Sincerely yours
Eugene Mayevski
Posted: 07/14/2006 15:47:23
by Bill Armstrong (Basic support level)
Joined: 07/14/2006
Posts: 22

I'm using OpenSSH version 4.2p1 (its the version that is included in the SUSE Linux 10.1 distribution).
Posted: 07/15/2006 02:04:56
by Eugene Mayevski (Team)

I have installed OpenSSH 4.21 on Windows and on Linux and authentication worked fine on both of these systems. No wonder - your report is the only one of this kind and OpenSSH 4.2 on Linux is a wide-spread server.
I think the problem can be in some specific configuration of your server. If you can setup some guest access (no rights except login itself), please use HelpDesk ( http://www.eldos.com/support/ticket_list.php, if you see "To support" button in Forum interface, you can use this button to move the message to support) and give us the login info. We will try to reproduce the issue with your server.

Sincerely yours
Eugene Mayevski
Posted: 07/17/2006 08:43:13
by Bill Armstrong (Basic support level)
Joined: 07/14/2006
Posts: 22

As I am new to the Linux world it is entirely possible that it is a configuration issue, although it would not explain why the other client is able to connect. The Linux installer installed OpenSSH by default and as far as I know I haven't done anything to change it from the default configuration.

Unfortunately I have no way of getting you access to my machine; however my Linux machine is actually a virtual machine running on VMWare Server. VMWare Server is free to download and use. If you have an FTP server that I can upload to, I can send you the virtual machine image and you can reproduce the problem that way.



Topic viewed 15501 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!