EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Office 365 smtp client connection

Posted: 03/10/2015 15:15:08
by Eduardo Helminsky (Standard support level)
Joined: 08/20/2010
Posts: 112


Almost a year ago I went here with a problem with send email to a office365 mailbox. I was oriented to do some changes (shown below) but for a week or so, it does not work anymore. I donĀ“t know if there were changes in office365. My application is the same (nothing has changed).

The base code is:
FSmtp is a TElSMTPClient component

FSmtp.Address := FHost;
FSmtp.Port := FPort;
FSmtp.Username := FUsername;
if FCript = scSSL then begin
// GMail
FSmtp.UseSSL := True;
FSmtp.SSLMode := smImplicit;
FSmtp.OnCertificateValidate := CertificateValidateHandler;
end else if FCript = scTLS then begin
// Office365
FSmtp.UseSSL := True;
FSmtp.SSLMode := smExplicit;
FSmtp.OnCertificateValidate := CertificateValidateHandler;
FSmtp.Versions := [sbSSL3];
end else begin
// Demais
FSmtp.UseSSL := False;
FSmtp.OnCertificateValidate := nil;
FSmtp.Login(cDomain); <-- Here it fails

*** I have already tried to isolate TLS1, TLS11, TLS12 but the problem is the same. The use of GMail and other servers are working OK.

I have seen the source and the problem occurs when the SSL connection should start. What can I do more to solve this problem ? I am still using v10 of SecureBlackBox.

The code in unit SBSMTPClient
if FUseSSL and (FSSLMode = smExplicit) then
EstablishSSLSession; <-- Here it fails
Posted: 03/11/2015 03:50:55
by Vsevolod Ievgiienko (Team)

Thank you for contacting us.

Currently a lot of servers upgrade their software to eliminate recent attacks on SSL protocol. Most likely office365 server was upgraded too.

The 1st thing to try is to disable SSL3 and leave only TLS1-1.2 enabled. You can also try to "play" with CipherSuites property - its possible that some set of ciphersuites will work.

If this doesn't help, then you should try to use the latest 12th version of SecureBlackbox as it includes different compatibility improvements.
Posted: 03/11/2015 07:26:49
by Eduardo Helminsky (Standard support level)
Joined: 08/20/2010
Posts: 112

I have tried to disable SSL3 and tried to change a lot of ChiperSuites without any success. Then I downloaded the latest 12th version and then the problem was solved.

Today I have MailBlackBox, SSLBlackBox, XMLBlackBox packages all in version 10. I would like to upgrade them to a complete version (Professional). Could you drive me how can I do that ?
Posted: 03/11/2015 07:38:16
by Vsevolod Ievgiienko (Team)

I would like to upgrade them to a complete version (Professional). Could you drive me how can I do that ?

I've created a Helpdesk ticket for you where you will receive an answer about upgrade options. You will also receive a notification about this ticket by e-mail.



Topic viewed 611 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!