EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Password not recognized when using Sample generated ETFI keys in Putty

Also by EldoS: CallbackDisk
Create virtual disks backed by memory or custom location, expose disk images as disks and more.
#30519
Posted: 08/28/2014 12:29:00
by Tom Dyess (Standard support level)
Joined: 03/19/2012
Posts: 4

I'm stuck. I've generated a key using the sample app with the following parameters:

RSA
IETF
2048 bit

I save the public and private key. When I try to import the private key into another app: Putty, WS_FTP, FileZilla, the password I entered is incorrect. I've tried several passwords and I'm not mistyping them. Any ideas?

This is using the latest build on VS2012 for C#.

Thanks,
Tom
#30520
Posted: 08/28/2014 13:38:26
by Eugene Mayevski (EldoS Corp.)

Various applications use different formats of SSH key files. Try using OpenSSH and Putty formats. I am not sure that those applications understand IETF format.


Sincerely yours
Eugene Mayevski
#30521
Posted: 08/28/2014 13:40:32
by Ken Ivanov (EldoS Corp.)

Hello Tom,

Thank you for contacting us.

With private keys, Putty only understands its own private key format; it doesn't support private keys in OpenSSH or IETF formats. I can't say for sure about the WS_FTP (it is a good idea to start with OpenSSH-formatted keys though), but as FileZilla's SSH support is built on top of Putty, it will not handle keys in OpenSSH and IETF formats either.

Ken
#30522
Posted: 08/28/2014 13:52:53
by Tom Dyess (Standard support level)
Joined: 03/19/2012
Posts: 4

Ken,

I tried importing the generated private key into Putty for conversion and it recognized the key but wouldn't accept the password. The private key is encrypted, does that have anything to do with it?

---- BEGIN SSH2 ENCRYPTED PRIVATE KEY ----
P2/56...
---- END SSH2 ENCRYPTED PRIVATE KEY ----


Eugene,

The server I'm connecting to only accepts IETF keys, they use WS_FTP and require both username/password and SSH2 key authorization. They will accept the public key, but I get an auth failed when using the private key via the WS_FTP client.

Here is the connection log:

Server Welcome: SSH-2.0-1.82_sshlib GlobalSCAPE
Client Version: SSH-2.0-WS_FTP-12.4.1-0
RSA Signature Verified
Session Keys Created
Ciphers Created
New Client->Server ciphers in place.
New Client->Server ciphers in place.
Completed SSH Key Exchange. New Keys in place.
Trying authentication method: "password"
EFT Server Enterprise 6.4.4 Build 03.22.2012.1
Trying authentication method: "publickey"
Failed SSH User Authentication
SSH Transport closed.

Thanks for your help,
Tom
#30523
Posted: 08/28/2014 14:05:51
by Ken Ivanov (EldoS Corp.)

Tom,

Thank you for the details.

IETF is just one of possible key formats. That is, you can save your public key in IETF format for your Globalscape server and your private key in Putty format for Putty or OpenSSH format for WS_FTP, and both files will contain the same key material.

Quote
They will accept the public key, but I get an auth failed when using the private key via the WS_FTP client.

And does WS_FTP actually indicate that the private key was loaded correctly in some way?

We suggest that you start with unencrypted private keys and check whether you are able to make your environment work in this way. If password-less configuration will work, we could move on and try to introduce passwords to the scheme.

Ken
Also by EldoS: CallbackProcess
A component to control process creation and termination in Windows and .NET applications.

Reply

Statistics

Topic viewed 752 times

Number of guests: 1, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!