EldoS | Feel safer!

Software components for data protection, secure storage and transfer


Posted: 08/26/2014 02:12:07
by Kim Bracknell (Basic support level)
Joined: 08/26/2014
Posts: 2

Hi there,

I just installed CryptoBlackBox in XE5 (Win 7 64-bit environment).

The first sample I tried was the CertDemo.
I immediately get a compile error as follows:
[dcc32 Error] frmMain.pas(131): E2003 Undeclared identifier: 'TElByteArrayList'
Google search gives me no clues.

I have previously added the Source folder to the library path.

In which unit can TElByteArrayList be found?

Many thanks,
Posted: 08/26/2014 02:15:25
by Vsevolod Ievgiienko (Team)

Thank you for contacting us.

TElByteArrayList is located in SBUtils unit.
Posted: 08/26/2014 02:25:53
by Kim Bracknell (Basic support level)
Joined: 08/26/2014
Posts: 2

Thanks Vsevolod,

However, even if I use SBUtils as prefix (i.e. FAvailableCurves : SBUtils.TElByteArrayList;) I still get the compile error.

TElByteArrayList does not appear if I start typing SBUtils... it is not visible?

Posted: 08/26/2014 02:30:00
by Vsevolod Ievgiienko (Team)

Please refer to the source code of the unit for details.



Topic viewed 598 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!