EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Problem using FTPSDemi (FTPS client) and FTPSServerDemo

Posted: 04/03/2014 15:09:35
by Alin Bigan (Standard support level)
Joined: 09/25/2012
Posts: 2

I try to use FTPSSimpleClient and I start using your demo applicatios.
1. I start on, my computer (windows & ent edition 64bits)the Server app and I try to connect using client app. I receive the 'control channel transfer error'.
2. I try to connect from another computer to server, running on my computer, using Filezila client. I receive the same error.
3. I try to connect from my computer with the demo client to IIS 7.5 (win 2008 R2) configurated as FTP server with SSL but I receive the same error.
I have Blackbox Version 9.1.217. Released on 2012-09-10 vcl ed. using Delphi XE2 ent. edition.
I attach the param used in app.

please help.

Posted: 04/03/2014 15:15:02
by Eugene Mayevski (Team)

Please check if the described issues occur in version 11 (release) or version 12 (beta). The FTP server component just appeared in version 9 and it's possible that the build you are using has some issue that has been addressed in later versions.

If you need to check FTP client operations, there exist plenty of servers on the market with which the client component can connect, such as gene6, FileZilla server and more.

Sincerely yours
Eugene Mayevski
Posted: 04/03/2014 15:59:19
by Alin Bigan (Standard support level)
Joined: 09/25/2012
Posts: 2

My target is the FTPSClient, I have to make a program to transfer some files, I try all scenarios because I felt, in first instance, in using FTPS client connecting to FileZila server (the same error), point 3 in my post (it seems I make a big mistake with enumeration of scenarios first I try to connect with FTPS client to FileZila server).
There is another problem I have licence only for 9 version so I can not use 11 or 12.

thank you for your light speed response.
Posted: 04/04/2014 02:07:59
by Eugene Mayevski (Team)

Are you sure that you need to connect to port 990 and implicit TLS? If yes, then you have not enabled SSL in the sample.

Sincerely yours
Eugene Mayevski



Topic viewed 516 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!