EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Trying a Get Request

Also by EldoS: CallbackProcess
A component to control process creation and termination in Windows and .NET applications.
Posted: 11/16/2013 02:28:30
by Jeff Newlin (Standard support level)
Joined: 12/26/2010
Posts: 19


I just want to make sure I'm using the correct component - HTTPSClient.

I am trying to use HTTPSClient to send this request


using the GET method (passing the entire string above)

When I try to do this I get "Invalid Address (error code is 96260)"

Do I need to separate the parameters - or maybe I'm not using the correct component?

I'm just a little new to this!

Thanks for your help!
Posted: 11/16/2013 02:32:21
by Eugene Mayevski (EldoS Corp.)

You need to encode all non-alphanumeric characters in parameters, so that your URL looks like


(newlines are put to fool the forum engine).

This is required by the standard.

The component can't do this for you because before encoding the component needs to parse what you've passed and this can be impossible (such as in your case where at sign is treated as a separator before domain name).

Sincerely yours
Eugene Mayevski
Posted: 11/16/2013 02:57:37
by Jeff Newlin (Standard support level)
Joined: 12/26/2010
Posts: 19

Thanks Eugene that's got me going again!



Topic viewed 584 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!