EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Errors upgrading from 7.2.167 to 11.0.240

Also by EldoS: MsgConnect
Cross-platform protocol-independent communication framework for building peer-to-peer and client-server applications and middleware components.
Posted: 10/22/2013 04:22:10
by Romana Romandini (Standard support level)
Joined: 10/22/2013
Posts: 29

Hi, my project uses an old version of VCL secure black box (version 7.2.167) and it works *well*. It has some bugs and i want to verify if with the 11.0.240 they are fixed.

I downloaded and installed the 11.0.240 trial, but when reopening my project i have this error:
Exception EReadError in module ftps.exe at 0001E786.
Error reading ElSimpleSFTPClient1.ObfuscateHandshake: Property ObfuscateHandshake does not exists.

I tried to rollback to 7.2.167, created new project, just grabbed inside ElSimpleSFTPClient and ElSftpClient components, successfully compiled, salved, closed delphi, upgraded to 11.0.240 using the installer, re-opened delphi and the same error appears.

I can't find any "how to upgrade" thread nor any information about this error on this site.
How i can fix this?

Thank you!
Posted: 10/22/2013 04:27:01
by Vsevolod Ievgiienko (EldoS Corp.)

Thank you for contacting us.

The new project references an old versions of SecureBlackbox units. You can try to add directory with new units to your project search path in project settings.
Posted: 10/22/2013 04:40:07
by Mykola Olshevsky (Basic support level)
Joined: 07/07/2005
Posts: 450

Hi. Some properties were added since SBB 7 (including ObfuscateHandshake), and looks like Delphi cannot correctly load them from dfm file/set defaults.
You can open dfm file and add it and other properties manually.
Posted: 10/22/2013 04:46:29
by Romana Romandini (Standard support level)
Joined: 10/22/2013
Posts: 29

Hi, thank you for your answer.
When i re-open my delphi (the first opening was ok!) i got a lot of errors:

The procedure entry point @$xp$17Sbtypes@ByteArray could not be located in the dynamic link library BaseBBoxD12.bpl

After this it says it can't load DCBBoxD12.bpl because the specified procedure is not found.

This error reiterates 7 times and some of the .bpl are located in C:\Windows\System32\

When i open my test project i get all the previous errors again and it can't find the 2 components i've added (they are disappeared from the form)

If i go to menu "Components -> install package", select EldoS SFTPBlackbox client and click "Components" i have an empty component list

Selecting the EldoS SFTPBlackbox client i see the right path of the .bpl package on the bottom.

Something is going crazy! How i try to fix? I'm using Delphi 2009

edit: looks like everytime i reinstall SecureBlackBox the first run is ok and i get only the Handshake Obfuscator error, after that i always get lot of errors when opening delphi and when opening my empty test project
Posted: 10/22/2013 04:57:37
by Eugene Mayevski (EldoS Corp.)

As Vsevolod has said, the problem is with older modules being loaded and referenced.

There's a copy of BPL files (*BBox*.bpl) in Windows\System32 folder. If those are of old 7.2 version, the IDE most likely load them instead of newer files. So you need to remove them.

Sincerely yours
Eugene Mayevski
Posted: 10/22/2013 05:12:58
by Romana Romandini (Standard support level)
Joined: 10/22/2013
Posts: 29

Thank you for your response again!

I deleted all the *BBox*.bpl files inside Windows\System32\ folder, renamed the old folder of the installation files for version 7.2.167, but delphi starts without errors only the first time i run it.

Same result if i install, open delphi without opening any project, close and reopen delphi. It copies all the files again in Windows\System32 folder but looks like it copies the new ones (last edit time 6 october 2013)

any ideas?
Posted: 10/22/2013 05:21:36
by Eugene Mayevski (EldoS Corp.)

Installation does install the BPLs to System\Windows32 folder. But maybe there's another copy of old BPL files somewhere, and that older copy is being loaded.

In general if you need only version 11 (and not side-by-side installation), then you should uninstall SecureBlackbox, remove all files left by hand and then install everything from scratch. This is described in the Knowledgebase.

Sincerely yours
Eugene Mayevski
Posted: 10/22/2013 05:54:57
by Romana Romandini (Standard support level)
Joined: 10/22/2013
Posts: 29

Thank you! I simply followed what you linked in the Knowledgebase and now it works, i finally can test the latest version :)

Thank you again!
Also by EldoS: CallbackRegistry
A component to monitor and control Windows registry access and create virtual registry keys.



Topic viewed 1810 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!