EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Timestamp error

Also by EldoS: CallbackDisk
Create virtual disks backed by memory or custom location, expose disk images as disks and more.
Posted: 08/02/2013 04:15:16
by Volkan Karakaya (Basic support level)
Joined: 08/02/2013
Posts: 9

Hi there,

I am trying to sign and timestamp a string data using the C# example CMSManager_VS2010. I am signing data with my certificate, but i cannot timestamp data. I use 3 different timestamping server;

1) https://teszt.e-szigno.hu:440/tsa2
2) http://timestamping.edelweb.fr/service/tsp
3) http://ca.signfiles.com/TSAServer.aspx

I get the error 2 and 3 server “Failed to timestamp the message: Failed to timestamp signature (error 83973)”. First server error as for “Failed to timestamp the message: Certificate validation handler is not assigned. Please handle the OnCertificateValidate event and implement proper certificate validation code there.”

I guess I am missing something, any help is welcome.

Thanks in advance
Posted: 08/02/2013 04:23:33
by Vsevolod Ievgiienko (Team)

Thank you for contacting us.

83973 error code stands for SB_TSP_ERROR_WRONG_DATA error that means "invalid response data". Its possible that server is not TSP compliant and performs timestamping using some other protocol. We'll check this now if these server doesn't require authnetication.

Exception message is self-explaining. As its HTTPS URL you should assign OnCertificateValidate event handler. This handler should be assigned to TElHTTPSClient instance that is in turn assigned to TElHTTPTSPClient.HTTPClient property.
Posted: 08/02/2013 04:24:38
by Eugene Mayevski (Team)

Regarding server 3: the correct URL is http://ca.signfiles.com/tsa/get.aspx ( see info on http://www.signfiles.com/timestamping/ )

Sincerely yours
Eugene Mayevski
Posted: 08/02/2013 04:36:22
by Vsevolod Ievgiienko (Team)

The 2nd server works correctly with the latest SecureBlackbox version. What version do you use?

The 1st one requires authentication. Please implement OnCertificateValidate event as described above and check if it works.
Posted: 08/02/2013 04:52:06
by Volkan Karakaya (Basic support level)
Joined: 08/02/2013
Posts: 9

Thanks for your quick reply,

I use SecureBlackBox trail version and I try the 2nd server, CMSManager_VS2010 throw same error:

Failed to timestamp the message: Failed to timestamp signature (error 83973)
Posted: 08/02/2013 04:59:20
by Vsevolod Ievgiienko (Team)

Please try to use the latest 11th version that can be downloaded here: https://www.eldos.com/sbb/download-prerelease.php I've just re-checked this server and it works.
Posted: 08/02/2013 05:05:11
by Volkan Karakaya (Basic support level)
Joined: 08/02/2013
Posts: 9

Ok, I'm trying again.

Posted: 08/02/2013 05:47:16
by Volkan Karakaya (Basic support level)
Joined: 08/02/2013
Posts: 9

Hello again,

This time I use SecureBlackBox 11 but I got still same error.

SecureBlackBox C# Samples: CMSManager_VS2010
Access to the timestamp server; http://timestamping.edelweb.fr/service/tsp
My development envoriment; Windows 8 Pro x64, Visual Studio Ultimate 2012 Update 3

What am i doing wrong?
Posted: 08/02/2013 05:50:01
by Vsevolod Ievgiienko (Team)

Its possible that an old versions of assemblies are loaded instead of the 11th versions. Please check this.
Posted: 08/02/2013 06:08:33
by Volkan Karakaya (Basic support level)
Joined: 08/02/2013
Posts: 9

First of all uninstall SecureBlackBox 10, after install SecureBlackBox 11.

Also by EldoS: Solid File System
A virtual file system that offers a feature-rich storage for application documents and data with built-in compression and encryption.



Topic viewed 1856 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!