EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Windows Service deployment issues

Posted: 03/06/2007 11:53:52
by Gary Loftus (Basic support level)
Joined: 12/19/2006
Posts: 19

I am having a problem deploying a windows service which incorporates SecureBlackBox SFTP client onto a windows 2003 server. I have published and installed the service successfully and created the service using InstallUtil.

I had this issue on a different windows 2003 server and only managed to resolve it by installing Visual Studio 2005 onto the server and then installing the SecureBlackBox package and integrating the two together. I cannot do that on this server (nor would I wish to). The .NET Framework is installed on both servers.

When I install the code as an application rather than a service it works fine.

Has anyone had any similar issues and, if so, how did they resolve them?

thanks in advance.
Posted: 03/06/2007 12:13:03
by Eugene Mayevski (Team)

What is the actual problem?

Sincerely yours
Eugene Mayevski
Posted: 03/06/2007 12:17:14
by Gary Loftus (Basic support level)
Joined: 12/19/2006
Posts: 19

The error message that is coming up is system.io.filenotfoundexception
Posted: 03/06/2007 12:30:41
by Eugene Mayevski (Team)

Great. Did you try to find the file that was not found?
Obviously you just didn't copy some necessary file.

Sincerely yours
Eugene Mayevski
Posted: 03/07/2007 04:53:52
by Gary Loftus (Basic support level)
Joined: 12/19/2006
Posts: 19

This is where I am having the problem. I have tried to catch the exception in my app but the service is failing to start so I cannot find which file it is that is needed.
Posted: 03/07/2007 05:37:11
by Eugene Mayevski (Team)

If you assume that it's SecureBlackbox' issue, then you need to check whether you've included all necessary assemblies. Please check the documentation regarding what assemblies must be included. For example, you always need to include SecureBlackbox.PKI (and most people miss it as it is not explicitly referenced).

Sincerely yours
Eugene Mayevski
Posted: 03/07/2007 05:45:00
by Gary Loftus (Basic support level)
Joined: 12/19/2006
Posts: 19

I am confused because the same code running as an application runs perfectly on the same server. It is only when I run it as a service that it fails.

I have gone in the .Net publisher and set all pre-requisites to include. Below is a list of all the files I am including when publishing:-


I know if I install Visual Studio 2005 and then install and integrate SecureBlackBox that the service will work.

The only thing I can think of is that there is some link between dlls that doesn't work if you use InstallUtil.exe rather than publishing.

I was posting onto the forum mainly to see if this is an issue that has occured before with SecureBlackBox and .NET services.
Posted: 03/08/2007 01:21:36
by Eugene Mayevski (Team)

0) All Interop* assemblies are not needed. Don't know why you picked them - they are wrappers for ActiveX edition.
1) You don't need server components if you only use a client. But this doesn't do harm.
2) try adding the assemblies to GAC.

Sincerely yours
Eugene Mayevski



Topic viewed 3788 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!