EldoS | Feel safer!

Software components for data protection, secure storage and transfer

XMLBlackbox not working properly anymore

Posted: 04/24/2013 05:45:40
by Ɓukasz Palka (Basic support level)
Joined: 04/24/2013
Posts: 1


I've been trying to use your library for signing XML using XAdES. I've managed to use your example, AdvancedSigner and write my own application on February 2013. On that time I used version 10.0.230. From that moment I haven't been using it, I've moved to new machine (old is gone) and I've installed version 10.0.233. Generated signature is no longer verified correctly by 3rd party software that we use. I tried to generate signature also with your sample application, AdvancedSigner, and the result is the same. The 3rd party app is created by some kind of government/high level banking institution/organisation in Poland, so the demand is, that signed XML files should be verifiable by their app: http://elektronicznypodpis.pl/en/our-offer/digital-signature-applications (Szafir verifying application).

I tried to use version 9.1.217 and it works OK - it produces verifiable signature, but I cannot use SBX509.TElX509Certificate.ToX509Certificate2(Boolean) anymore, because of an exception:

System.TypeInitializationException: The type initializer for 'XMLSignService.Signer' threw an exception. ---> System.MethodAccessException: Attempt by security transparent method 'SBX509.TElX509Certificate.ToX509Certificate2(Boolean)' to call native code through method 'SBWinCrypt.__Global.CertDuplicateCertificateContext(IntPtr)' failed.  Methods must be security critical or security safe-critical to call native code.
   at SBX509.TElX509Certificate.ToX509Certificate2(Boolean CopyPrivateKey)
   (rest cut)

I use this method to obtain X509Certificate2 to programmatically set the PIN for smartcard as presented here: http://www.infinitec.de/post/2010/11/22/Setting-the-PIN-of-a-smartcard-programmatically.aspx

Can you do one of the following to help me:
-provide previous version of SecureBlackbox, ie. 10.0.230
-help me with the MethodAccessException
Posted: 04/24/2013 06:02:20
by Dmytro Bogatskyy (Team)

Moved to HelpDesk.



Topic viewed 749 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!