EldoS | Feel safer!

Software components for data protection, secure storage and transfer

HTTPS error

Posted: 04/17/2013 13:33:35
by Eduardo Helminsky (Standard support level)
Joined: 08/20/2010
Posts: 112

I am consuming a WebService with SSL and the steps from the problem are:

1) The event CertificateValidate is fired.
2) The event CertNeedEx is fired.
3) Error message "EElASN1Read error" with message "Invalid size" and according with CipherSuited enabled sometimes it "Block Size too large"
4) Connection lost 10058
5) and then I received the SOAP Response

Last week I posted a message with connection problem and it has solved with a instruction from Eldos Support like below:

for nI := SB_SUITE_FIRST to SB_SUITE_LAST do begin
FHttpsClient.CipherSuites[nI] := False;
FHttpsClient.CipherSuites[SB_SUITE_RSA_3DES_SHA] := True;
FHttpsClient.CipherSuites[SB_SUITE_RSA_RC4_SHA] := True;
FHttpsClient.CipherSuites[SB_SUITE_RSA_AES128_SHA] := True;
FHttpsClient.CipherSuites[SB_SUITE_RSA_AES256_SHA] := True;
FHttpsClient.CipherSuites[SB_SUITE_RSA_DES_SHA] := True;

I have tried enabling from 0 to 49 and from 143 to 166 unsuccessfully.

What should I do to solve this problem ?
Posted: 04/17/2013 13:40:59
by Eugene Mayevski (Team)

EElASN1ReadError seems to be internal one and should not happen when you run the application not from Delphi IDE (well, it happens but it's handled internally). "Block size too large" needs reproducing.

Connection Lost error (EElSocketError exception in fact) has the same nature as EElASN1ReadError - it should be handled internally and not be visible in IDE.

Please see this Delphi article regarding how to suppress exceptions in IDE.

Sincerely yours
Eugene Mayevski



Topic viewed 644 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!