EldoS | Feel safer!

Software components for data protection, secure storage and transfer

SSH Tuneling

Posted: 02/14/2013 14:57:27
by Ken Ivanov (Team)

Thank you for the details.

At first glance it looks like the server fails to pass the forwarded connection on to the FTP server. The FTP client apparently connects to the local port just fine, and a logical channel between the SSH client and the SSH server is also established (though immediately terminated). Could you please check that you are specifying the correct FTP server's address and port in the relevant edit boxes? Please also try to use as the forward-to address instead of the public address of the FTP server.
Posted: 02/14/2013 16:08:03
by Andre Paradis (Standard support level)
Joined: 02/14/2013
Posts: 31

Destination host is the Host IP and port is 21.
Posted: 02/14/2013 16:13:51
by Ken Ivanov (Team)

And did you try setting as the forwarding address?
Posted: 02/15/2013 14:33:59
by Andre Paradis (Standard support level)
Joined: 02/14/2013
Posts: 31

Yes I did.... No difference...I get the same log.
Posted: 02/15/2013 15:42:55
by Ken Ivanov (Team)


Thank you for checking that. I suspect we are missing some minor configuration-specific point here.

First of all, please try to set the ReportRealClientLocationToServer property of the forwarding component to true before connecting and check if it affects anything.

Just in case if adjusting the property doesn't help, are the FTP and SSH servers under your control - do you have access to their logs?
Posted: 02/18/2013 07:46:27
by Andre Paradis (Standard support level)
Joined: 02/14/2013
Posts: 31

No difference...
You seems very confident that it should work so I tried it on an other machine, with the same results.
Posted: 02/18/2013 07:47:09
by Andre Paradis (Standard support level)
Joined: 02/14/2013
Posts: 31

I don't have any control on the SSH/FTP server
Posted: 02/18/2013 08:24:37
by Ken Ivanov (Team)


Yes, it definitely should work as long as Putty does.

Another guess - please try to set the forwarding's CloseIfNoActiveTunnelsProperty to false before opening the tunnel and check if it changes anything. If this won't help, please try the following:

1) Run the sample and connect to the server.
2) Use telnet to connect to the forwarded port opened by the sample:

telnet 21

3) Check the sample's log control. Is the 'Secure channel closed' line reported there, just as it is when connecting with the FTP tool?
4) If telnet session remains active and no 'Secure channel closed' line is in the log, try to type something into the session (e.g. USER test) and check if the sample reports the characters as being transferred in the tunnel list control.
Posted: 02/18/2013 09:42:25
by Andre Paradis (Standard support level)
Joined: 02/14/2013
Posts: 31

I have set

I run the Program, the log show:
Server key received
Authentification succeded
SSH Connection established

Then I run the Telnet app and I get:
New secure channel opened
Secure channel closed

At this point telnet is still active, as soon I enter a letter, Telnet terminate. The log of the app doesn't change or flash, nothing happen.

I did the test with as the forwarding address as well, no differences.
Posted: 02/21/2013 06:15:06
by Ken Ivanov (Team)

Thank you for checking that and sorry for a late reply. All the symptoms indicate that the SSH server closes the forwarded connection for some reason right after it has been established. To be able to investigate the issue deeper, we would need some assistance from your side - unfortunately, it is not possible to guess the reason having without having a deeper look into what is happening within the client-server SSH communication.

I have created a Helpdesk ticket for you. Let's continue the discussion there.



Topic viewed 2265 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!