EldoS | Feel safer!

Software components for data protection, secure storage and transfer

FTPS - Control Channel Transfer Error

Also by EldoS: Solid File System
A virtual file system that offers a feature-rich storage for application documents and data with built-in compression and encryption.
Posted: 01/21/2013 19:40:24
by Blackjack60 (Basic support level)
Joined: 01/21/2013
Posts: 4

I am evaluating your FTPS unit using the FTPSDemo program. However, when I try to connect to a Windows 2008? server that requires FTP over Explicit TLS, I always get a "Control Channel Transfer Error". Any idea what could cause this?


Posted: 01/22/2013 00:54:24
by Vsevolod Ievgiienko (EldoS Corp.)

Thank you for contacting us.

Could you please clarify what SecureBlackbox edition do you evaluate (VCL, .NET, Java etc.) and attach here a log produced by our FTPSDemo sample.
Posted: 01/22/2013 06:16:45
by Blackjack60 (Basic support level)
Joined: 01/21/2013
Posts: 4

I'm using the VCL edition. The log only has three lines:

Connecting to myserver:21
Control channel transfer error
Posted: 01/22/2013 06:26:19
by Ken Ivanov (EldoS Corp.)

Are there any 'AUTH TLS' lines there in the main text box of the sample app? If there aren't any, please re-check that the "Use implicit SSL" check box on the connection properties dialog of the sample is turned off.

Besides, please try to connect with only SSL3 and TLS1 versions enabled and check if it changes anything.
Posted: 01/22/2013 06:36:03
by Blackjack60 (Basic support level)
Joined: 01/21/2013
Posts: 4

No, there are no lines in the main text box at all.

I verified that "Use implicit SSL" is off. I also tried to connect with only SSL3 and TLS1 enabled. No change in behavior.
Posted: 01/22/2013 06:40:59
by Vsevolod Ievgiienko (EldoS Corp.)

Are you able to connect to this server using some third-party client like FileZilla? Its possible that SSL/TLS is simply turned off on server side.
Posted: 01/22/2013 06:47:11
by Blackjack60 (Basic support level)
Joined: 01/21/2013
Posts: 4

Yes, FileZilla works properly. I think I figured this out. I took the FTPSDemo.exe and ran it on a different machine, and it worked. For some reason, some network traffic appears to be blocked on my development machine. At this point, I have no idea why, but that's what it looks like. This is clearly my issue, and not the fault of the component. Thanks for your help!
Also by EldoS: RawDisk
Access locked and protected files in Windows, read and write disks and partitions and more.



Topic viewed 3558 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!