EldoS | Feel safer!

Software components for data protection, secure storage and transfer

EDI BlackBox Proxy Settings problem

Also by EldoS: BizCrypto
Components for BizTalk® and SQL Server® Integration Services that let you securely store and transfer information in your business automation solutions.
Posted: 09/17/2012 02:34:07
by Iulian Hostiuc (Basic support level)
Joined: 09/17/2012
Posts: 1


We have the EDI BlackBox library from you and we are using it to generate and send AS2 Messages. Everything worked fine until one of our customers required the usage of a proxy.
We added the following code to the TElAS2Client object that is responsible for sending the actual HTTP Post:

as2Client.Proxy.Enabled = proxySettings.Enabled;
as2Client.Proxy.Host = proxySettings.Host;
as2Client.Proxy.Port = proxySettings.Port;
as2Client.Proxy.UserName = proxySettings.UserName;
as2Client.Proxy.Password = proxySettings.Password;

int result = as2Client.Send(this._gatewayLink, sendingAs2File, receiptFile);

The proxy settings look something like this:
Host: proxy.domain.com
Port: 8080
Password: ...

Unfortunately the message does not get through the proxy and we receive Connection Error:
Connection error 10060 Connection error 10060 at SBSimpleSSL.TElCustomSimpleSSLClient.Open()
at SBHTTPSClient.TElHTTPSClient.PerformRequest(Int32 Method, String URL)
at SBHTTPSClient.TElHTTPSClient.Post(String URL, Stream Content, Boolean CloseStream)
at SBAS2.TElAS2Client.Send(String URL, Stream Message, Stream Receipt)
at SBAS2.TElAS2Client.Send(String URL, String MessageFile, String ReceiptFile)

What could the problem be? Should we use the Proxy settings in the AS2Client object some other way or are the proxy settings not correctly formed?

Posted: 09/17/2012 02:43:44
by Vsevolod Ievgiienko (EldoS Corp.)

Answered in Helpdesk.



Topic viewed 846 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!