EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Error #6 in sample SFTP server

Posted: 12/02/2006 18:46:50
by TJ Kolev (Standard support level)
Joined: 12/02/2006
Posts: 6


I am evaluating the .Net package of SFTPBlackBox. I build and ran the sample SSHServerDemo and tried to connect to it using FileZilla 2.2.22. However it won't connect. Here's the messages on the server:

ServerListener.Listen: New connection available
Connection accepted. Active connections 1 from 20
SSH session started
Error #6
SSH session closed

SSHServer_OnError() in SSHSession.cs is called from within m_SSHServer.DataAvailable() at line 507.

Here is the log from FileZilla:

Status: Connected with, initializing SFTP connection...
Command: CONNECT springcm@
Trace: SftpControlSocket.cpp(2596): OnReceive(0) caller=0x003fd52c
Trace: FzSFtp.exe: Ssh.c(788): Server version: SSH-2.0-EldoS.SSHBlackbox.4
Trace: FzSFtp.exe: Ssh.c(788): We claim version: SSH-2.0-PuTTY_FZ_Local:_Apr_20_2006_21:08:09
Trace: FzSFtp.exe: Ssh.c(788): Using SSH protocol version 2
Trace: FzSFtp.exe: Ssh.c(5333): Doing Diffie-Hellman group exchange
Trace: FzSFtp.exe: Ssh.c(7511): Received disconnect message (SSH_DISCONNECT_COMPRESSION_ERROR)
Trace: FzSFtp.exe: Ssh.c(7515): Disconnection message text: Invalid packet
Response: Ssh.c(7520): Server sent disconnect message
Trace: FzSFtp.exe: "Invalid packet"
Response: Fatal: Server sent disconnect message
Response: "Invalid packet"
Trace: SftpControlSocket.cpp(2393): DoClose(4) caller=0x003fd52c
Trace: SftpControlSocket.cpp(2423): ResetOperation(4100) caller=0x003fd52c
Error: Unable to connect!

I would appreciate any suggestions on how to make it work.

Best regards,
TJ Kolev
Posted: 12/03/2006 03:05:31
by Eugene Mayevski (Team)

1) Please specify the version of SecureBlackbox. If you are using SecureBlackbox 4, try SecureBlackbox 5 beta. We will not be able to support SBB 4 as it's not being developed anymore.
2) Try other client, such as OpenSSH - FileZilla has certain amounts of bugs which make it hard to diagnose the problems.

Sincerely yours
Eugene Mayevski
Posted: 12/03/2006 13:17:57
by TJ Kolev (Standard support level)
Joined: 12/02/2006
Posts: 6

Hello. I downloaded and installed the beta version. Same result - fails with error #6. I also tried it the following clients:

Bitvise Tunnellier

Also fails with the same result. I am starting to think my setup is wrong. I am running this on XP Pro SP2. I run both the server and the clients on the same machine.

Additionally your sample does not compile. Lines 261 adn 261 in SSHSession.cs:

Echoes.set_Bits(0, true);
Echoes.set_Bits(1, false);

Should be changed to:

Echoes[0] = true;
Echoes[1] = false;

(Smpales not compiling a good sign it is not.)

Next suggestions?

Thank you!
tjk :)
Posted: 12/03/2006 14:03:34
by Eugene Mayevski (Team)

The samples were not updated for SBB 5 yet. Transition to different compiler causes certain incompatibilities.

I think that you indeed didn't do something. First thing to check is whether you have generated and set a server key. Second thing is to add some user.

Sincerely yours
Eugene Mayevski
Posted: 12/03/2006 21:05:21
by TJ Kolev (Standard support level)
Joined: 12/02/2006
Posts: 6

Indeed. I had not set a server key.

Thank you!
tjk :)
Posted: 12/04/2006 11:28:22
by Eugene Mayevski (Team)

Great. I've updated the sample so that it doesn't even start without a key :).

Sincerely yours
Eugene Mayevski



Topic viewed 5232 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!