EldoS | Feel safer!

Software components for data protection, secure storage and transfer

SFTP & Notepad causes "No such file" error

Also by EldoS: CallbackProcess
A component to control process creation and termination in Windows and .NET applications.
Posted: 02/22/2012 05:27:07
by Stanisław Jankowski (Basic support level)
Joined: 12/06/2011
Posts: 20


I am testing SFTPDisk sample. The strange thing appears when I try to modify text file using Notepad. It is unfortunately not 100% reproducible.

Steps to achieve error:

1. Open a text file with Notepad. (the size of my test file was about 2MB)
2. Mark and erase part of the file.
3. Enter ctrl+s to save.

Result - sometimes it works, but sometimes I achieved MessageBox with error: "No such file".

I also add some log entries to SFTPDisk to investigate the issue:

105944 [13] DEBUG SftpDisk.MainForm - WriteFile call: \Legacy\Nowy dokument tekstowy.txt bytes to write: 1980331 Position: 0
A first chance exception of type 'SBSftpCommon.EElSFTPError' occurred in SecureBlackbox.SFTP.dll
A first chance exception of type 'CallbackFS.ECBFSError' occurred in SftpDisk.exe
106006 [13] ERROR SftpDisk.MainForm - Handle error: No such file
106006 [13] ERROR SftpDisk.MainForm - Handle other error: No such file

I found that the error appears only if the SFTPDisk wants to write from the beginning of the file (Position = 0). It seems like the SFTP library loses the file handle.

I am using .NET edition of CallbackFS in Visual Studio 2010 and .NET framework 4.0 on Windows 7 64bit. On the server i have OpenSSH 5.9 running on Centos.

best regards,
Posted: 02/22/2012 05:37:19
by Alexander Ionov (Team)


Thank you for your report. Could you please download our free SFTP Net Drive application and try to do same things with it? If the problem persists then a reason probably is not in SftpDisk sample.

I'll try to reproduce the issue on our test OpenSSH server and see if something goes wrang.

Best regards,
Alexander Ionov
Posted: 02/22/2012 05:41:42
by Stanisław Jankowski (Basic support level)
Joined: 12/06/2011
Posts: 20

I get the same error with SFTP Net Drive.

Posted: 02/22/2012 05:57:14
by Stanisław Jankowski (Basic support level)
Joined: 12/06/2011
Posts: 20

It is probably server issue. Because when I am using alternative ssh server then everything is ok.
Posted: 02/22/2012 07:50:08
by Alexander Ionov (Team)

Unfortunatelly a lot of server issues happens. Some of them caused by servers configuration and/or file access rights, others - by sftp protocol implementations differences. We spent a lot of time to have SFTP Net Drive working with most commonly used servers. However we still get such reports from time to time.

Best regards,
Alexander Ionov
Also by EldoS: Callback File System
Create virtual file systems and disks, expose and manage remote data as if they were files on the local disk.



Topic viewed 1423 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!