EldoS | Feel safer!

Software components for data protection, secure storage and transfer

using SecureBlackBox PGP with VS 2010 targeting 3.5

Also by EldoS: CallbackFilter
A component to monitor and control disk activity, track file and directory operations (create, read, write, rename etc.), alter file data, encrypt files, create virtual files.
#19137
Posted: 02/21/2012 04:23:53
by Frank Munsberg (Standard support level)
Joined: 06/04/2009
Posts: 47

Actually I just now encountered that very same Warning on different VS 2010 projects that all use SBB. I'm kind of glad that I'm not the only one with this weird message. I've attached a screenshot of the message, maybe Phil had a similar message box popping up.
The target framework of all projects is 3.5 (not client profile). One project uses the SecureBlackBox and SecureBlackBox.PGP and the other uses SecureBlackBox, SecureBlackBox.FTPS, SecureBlackBox.SFTP, SecureBlackBox.SFTPCommon, SecureBlackBox.SSHClient, SecureBlackBox.SSHCommon and SecureBlackBox.SSLCommon. All in Version 9.1.214 downloaded an hour ago (although the installed .dll Versions seem to be 9.1.215)

The project using PGP stuff isn't giving me compiler warnings anymore but the project using all that FTP stuff is handing out some irritating warnings saying:

"the primary reference "<my project dll>" could not be resolved because it has an indirect dependency on the .NET Framework assembly "System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" which has a higher version "4.0.0.0" than the version "2.0.0.0" in the current target framework."

I'm going to test what will happen when the application runs on a machine without .Net 4.0 installed later today. If that would screw up I'd fall back to SBB 8.x for the time being, rather than having our server admins at my throat on rollout.


#19139
Posted: 02/21/2012 05:03:40
by Eugene Mayevski (EldoS Corp.)

I've just created .NET 3.5 project with references to Base and PGP assemblies for .NET 2.0. I've added references by using Browse tab and explicitly adding files from <SecureBlackbox>\Assemblies\NET_20 folder (that was build 214 but I don't think this matters).

I've put TElPGPWriter from toolbox to the main form and started the application. It worked fine.

Quote

'AssemblyVerTest.vshost.exe' (Managed (v2.0.50727)): Loaded 'C:\WINDOWS\assembly\GAC_MSIL\SecureBlackbox\9.1.214.0__5a62fa96d0ac431a\SecureBlackbox.dll'
'AssemblyVerTest.vshost.exe' (Managed (v2.0.50727)): Loaded 'C:\WINDOWS\assembly\GAC_MSIL\SecureBlackbox.PGP\9.1.214.0__5a62fa96d0ac431a\SecureBlackbox.PGP.dll'


What am I doing wrong?
#19141
Posted: 02/21/2012 05:28:00
by Frank Munsberg (Standard support level)
Joined: 06/04/2009
Posts: 47

That's a good question, I have no idea if you're doing something wrong or if it is just me.
I just found out that the downloaded and installed SBB version here is indeed 9.1.215 so version numbers are allright, sorry for the confusion there.

I'm not using the GAC here, rather I'm referencing the files directly from the NET_20 folder. Actually I'm not too familiar with the whole GAC thing.

To get the message I have to do these steps:
Create a blank VS 2010 solution
add a class library project
change Target framework to .Net 3.5
if existing, remove reference to Microsoft.CSharp
Add reference to SecureBlackBox.dll from NET_20 folder

Then the messagebox from my previous post comes up.
It also does this for the other .dll's from the NET_20 folder.

I've also tried SBB 9.1.213 and there things seem ok, no message boxes and no warnings. Since your 9.1.214 is working too, maybe this got introduced in 9.1.215 ?
#19143
Posted: 02/21/2012 06:00:54
by Eugene Mayevski (EldoS Corp.)

Re-checked with build 215. No problem as well. And yes, I have .NET 4.0 installed on the computer. Are you sure that it's SecureBlackbox and not one of its dependent assemblies, that causes the problem?

If you run the application from IDE, the Output window in IDE contains output, part of which I quoted above (regarding assembly loading). Can you please copy complete output and post it here (maybe as a text file attachment)?
#19144
Posted: 02/21/2012 06:04:59
by Phil McIntosh (Standard support level)
Joined: 02/09/2012
Posts: 6

The screenshot Frank posted is the same message I was getting. For me, ignoring it and plowing ahead seems to be working, even on the client computer that does not have 4.0 installed. I am just using the PGP component and the base dll. One final test to do this week and we will know for sure.
#19199
Posted: 02/23/2012 07:54:52
by Frank Munsberg (Standard support level)
Joined: 06/04/2009
Posts: 47

I've did some more tests over the last days and I think the problem is gone here.

I was able to recreate the behaviour from my development machine in a blank Win 7 x64 VM with only VS 2010 and all available windows updates as per today installed.

I've installed SBB 9.1.213 and SBB 9.1.215 into two different directories, then added a reference to SecureBlackBox.dll into a blank .Net 3.5 Winforms application.
That produced the message box.

Then I've uninstalled SBB 9.1.215 and tried adding a reference again. No errors, all went well.
Maybe installing both versions in different directories wasn't such a good idea.

The same sort of fix worked on my development machine so right now I only have all the SBB .dll's on my disk somewhere without actually having SBB installed.
That's fine by me because all those .dll's are committed and tagged in our SVN anyway.

Setting up an extra VM to test all this might seem like complete overkill but I really rely on SBB a great lot here. We transfer and encrypt lots and lots of data so I'd rather have things working fine without mysterious errors. So far SBB has quite a great track record here :)
Also by EldoS: Rethync
The cross-platform framework that simplifies synchronizing data between mobile and desktop applications and servers and cloud storages

Reply

Statistics

Topic viewed 3579 times

Number of guests: 1, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!