EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Secure FTP file uploads

Also by EldoS: Solid File System
A virtual file system that offers a feature-rich storage for application documents and data with built-in compression and encryption.
Posted: 11/27/2006 12:59:36
by Kobin Bingham (Standard support level)
Joined: 10/02/2006
Posts: 15

If anyone has any ideas...
I'm getting a wierd reaction with the UploadFile command from the TElSimpleSFTPClient Object. I run a loop, uploading files from three different directories. In all three cases, I load the file twice, sending it to two different folders on the SFTP site. on the first two iterations, it loads the first file, then immediately deactivates my connection so i get a 'SFTP component not connected' error when i try to upload the file the second time. I tried reconnecting between the two commands, but that gives me a 'Wrong socket state' Error. Perhaps the strangest part is that the third itteration seems to work fine. The code i'm using is :

sftpConnection.UploadFile(localDirectory+'\'+sr.Name, remoteDirectory+'/'+sr.Name);
if sftpConnection.Active = False then
sftpConnection.Open(); sftpConnection.UploadFile(localDirectory+'\'+sr.Name, remoteDirectory2+'/'+archiveName);

Thanks for any help you can offer.
Posted: 11/27/2006 13:13:09
by Eugene Mayevski (EldoS Corp.)

Please specify the version and edition of SecureBlackbox that you are using.
Also, it would be nice if you could modify some of our samples and reproduce the behaviour with it. If it's reproducible, send us the sample. You can use HelpDesk ( http://www.eldos.com/support/ticket_list.php ) to send the files.

Sincerely yours
Eugene Mayevski
Posted: 11/27/2006 13:13:44
by Eugene Mayevski (EldoS Corp.)

BTW does the problem happen if you upload 2 different files one immediately after another?

Sincerely yours
Eugene Mayevski
Posted: 11/27/2006 13:32:05
by Kobin Bingham (Standard support level)
Joined: 10/02/2006
Posts: 15

Thanks for your timely response.
Version is: version 4.3.80 - Released March 11, 2006, not sure where to find the edition. It doesn't really matter what the second file is, because it seems that the act of calling the UploadFile function deactivates the connection. i.e., immediately after running that call, sftpConnection.Active is false. I'm not sure what i can do about reproducing it in a sample as i don't have a an SFTP site i'd be allowed to send the login to...
Anything else i can do to help?
Posted: 11/27/2006 13:40:56
by Eugene Mayevski (EldoS Corp.)

The edition can be .NET, VCL or ActiveX.

The version you use is old and I think that the problems should go away if you use 4.4.94

Sincerely yours
Eugene Mayevski
Posted: 11/27/2006 14:42:02
by Kobin Bingham (Standard support level)
Joined: 10/02/2006
Posts: 15

That seems to have fixed it, although it created a different issue. I'll adress that in another post. Thanks for your help.
Also by EldoS: CallbackProcess
A component to control process creation and termination in Windows and .NET applications.



Topic viewed 2585 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!