EldoS | Feel safer!

Software components for data protection, secure storage and transfer

TElSimpleSSLClient Open() exception error

#18825
Posted: 01/26/2012 09:18:42
by Przemek D (Basic support level)
Joined: 01/26/2012
Posts: 6

Hello,


I'm trying to run an example SimpleSSL client project on Windows 7 Phone emulator with latest SecureBlackbox trial package v9.1.213, Visual Studio 2010 SP1.

The TElSimpleSSLClient Open() call throws EElSimpleSSLClientError with message string "Connection error 96259". I couldn't find any documentation for this error.
The stack trace ends on the Open() call.

Host OS is Win7 x64.

Any help much appreciated.

Best regards,
Przemek

Code is:
Code
            var SecureClient = new SBSimpleSSL.TElSimpleSSLClient();

            SecureClient.OnCertificateValidate += new SBSSLCommon.TSBCertificateValidateEvent(SecureClient_OnCertificateValidate);
            SecureClient.OnError += new SBSSLCommon.TSBErrorEvent(SecureClient_OnError);
            SecureClient.OnCloseConnection += new SBClient.TSBCloseConnectionEvent(SecureClient_OnCloseConnection);
            SecureClient.OnExtensionsReceived += new SBSSLCommon.TSBExtensionsReceivedEvent(SecureClient_OnExtensionsReceived);
            SecureClient.OnRenegotiationRequest += new SBSSLCommon.TSBRenegotiationRequestEvent(SecureClient_OnRenegotiationRequest);
            SecureClient.OnCloseConnection += new SBClient.TSBCloseConnectionEvent(SecureClient_OnCloseConnection);

            SecureClient.Address = host;
            SecureClient.Port = 443;
            SecureClient.Enabled = true;
            Status("STARTING");
            SecureClient.Open();
#18826
Posted: 01/26/2012 09:26:21
by Vsevolod Ievgiienko (Team)

Thank you for contacting us

Could you please post here a test project that can be used to reproduce the problem.
#18827
Posted: 01/26/2012 09:58:39
by Przemek D (Basic support level)
Joined: 01/26/2012
Posts: 6

Thanks for the quick reply. Attached is the test project (rename to .zip).


#18828
Posted: 01/26/2012 10:01:06
by Vsevolod Ievgiienko (Team)

The attachment is missing. You can upload it using Helpdesk: https://www.eldos.com/helpdesk/index.php
#18829
Posted: 01/26/2012 10:08:35
by Przemek D (Basic support level)
Joined: 01/26/2012
Posts: 6

Done, Ticket # 20247.

Thanks,
Przemek
#18870
Posted: 01/31/2012 07:45:17
by Przemek D (Basic support level)
Joined: 01/26/2012
Posts: 6

Thanks Vsevolod, as you pointed in the ticket solution, it was the sbb assemblies not matching the project target OS version.

Thanks for your help!

Reply

Statistics

Topic viewed 1424 times

Number of guests: 1, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!