EldoS | Feel safer!

Software components for data protection, secure storage and transfer

FTP - Cannot connect to FTP site

Posted: 11/30/2011 23:39:33
by Jim Fleming (Priority Standard support level)
Joined: 11/30/2011
Posts: 3

I have written a client-side FTP application using the SSLBlackbox package (trial version). This application works fine from my development environment but not from the production environment. I am performing standard FTP (not SSL). I can use FileZilla in the production environment and successfully connect each time.

It looks as though, for some reason, the USER and PASS data is not being sent. The first trace in the attached screen capture of a Wireshark capture shows this session.

The second trace shows a Wireshark capture for the FileZilla session on the same server. I have blanked out the password.

I have deployed my application with the following SecureBlackbox files:

The Wireshark capture running the client with the SecureBlackbox library on my development system has a similar session as the FileZilla - the USER and PASS commands are shown being sent.

I'm using the standard FTP port (21).

Do you have suggestions for why the USER and PASS commands don't get sent in one environment and not the other? There is obviously something particular in the production system but I'm not sure what to look for. I initially suspected the firewall but I don't see why FileZilla would work if this were the case.

Thank you for your time.



Posted: 12/01/2011 02:00:19
by Vsevolod Ievgiienko (Team)

Thank you for contacting us.

Are you able to connect to the server using our sample application located in \EldoS\SecureBlackbox.NET\Samples\C#\FTPSBlackbox\Client\SimpleFTPS folder? If not then post here its log please.
Posted: 12/03/2011 22:47:25
by Jim Fleming (Priority Standard support level)
Joined: 11/30/2011
Posts: 3

I did a test with the sample client and it connects successfully. I'll go through the sample client code and see what I missed. Is there something obvious (a client property setting) that I should need to do that would cause my code to work on my system but not in the target system? Any suggestions? I have all the DLLs present in the folder (not using the GAC) with the .exe.


Posted: 12/04/2011 01:39:33
by Eugene Mayevski (Team)

There's Login method which needs to be called explicitly. Looks like you are missing the call.

Sincerely yours
Eugene Mayevski
Posted: 12/04/2011 20:50:32
by Jim Fleming (Priority Standard support level)
Joined: 11/30/2011
Posts: 3


I just saw your response and had been doing my own work to attempt to resolve this issue. Thanks for the response. I found the same thing was missing. I thought my prior experience with SFTP would provide me a model for what to do. I didn't realize until I did more testing and reading through the help file and sample code that the Login method was required. It is still strange it worked from my development environment without the Login method.

No matter. It all works now. I'll be getting the full license shortly.

Posted: 12/04/2011 22:26:03
by Eugene Mayevski (Team)

JFYI: FTP is very different from SFTP. Login in SFTP happens on SSH level, before SFTP subsystem is started. Login in FTP is done receiving FTP server's banner, and it's optional (who knows, maybe you want just to see the banner or your server doesn't require login due to implicit SSL with client-side certificates)

Sincerely yours
Eugene Mayevski



Topic viewed 1364 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!