EldoS | Feel safer!

Software components for data protection, secure storage and transfer

HTTPS Error 75778

Also by EldoS: RawDisk
Access locked and protected files in Windows, read and write disks and partitions and more.
#1595
Posted: 10/27/2006 17:01:25
by stephen kervin (Basic support level)
Joined: 10/27/2006
Posts: 5

Hi

I am evaluating SecureBlackbox for the purpose of downloading XMLs from a corporate HTTPs site. Using the supplied demo application I attemp to connect and it hangs. I added an error handler, and the error code returned is 75778. I do not valid the cert, nor need. The demo seems to pass validate = true, although debugging shows this is never called.

What does this error mean? I do NOT have TLS* enabled.

I then tried other sites like: Https://gmail.google.com
and this gives me ssl connection error (-1).

I cannot seem to connect to any SSL site.

What am I doing wrong? I am using the demo as is.
#1597
Posted: 10/28/2006 01:24:17
by Eugene Mayevski (EldoS Corp.)

Quote
stephen kervin wrote:
I do NOT have TLS* enabled.


You "enable" TLS by providing an URL with https:// prefix.

The error is given by some servers, that don't understand TLS 1.1. You need to turn off TLS 1.1 in code in order to connect to those servers.


Sincerely yours
Eugene Mayevski
#1599
Posted: 10/28/2006 05:08:16
by stephen kervin (Basic support level)
Joined: 10/27/2006
Posts: 5

The reason I mentioned TLS is because I have gone into the component and turned all the TLS to FALSE.

How do I "turn off TLS 1.1 in code"? Because apart from the properties on the compoenent I cant see any other way to do it, and even with it off the error continues to occur.
#1600
Posted: 10/28/2006 06:22:02
by stephen kervin (Basic support level)
Joined: 10/27/2006
Posts: 5

Ok I figured out part of it.

The port number addition which is part of your demo application seems to break SSL servers. e.g if I put in
Protocol: https
host: gmail.google.com
port: 80
Path: /
It doesnt work, although this doesnt cause 75778 error. If I put https://gmail.google.com:80 into a web browser this breaks too.

So I changed the code to use the url without a port, and now I can get it to work. eg. https://gmail.google.com

My only concern now is that when i do get that 75778 error in your demo application, the application hangs, stays at about 50% cpu and refuses to return. I put an OnError handler which also calls "cancelrequest" but the application still hangs.

I am writing an application that needs to be able to recover from any errors. It cannot hang. Even if exceptions are thrown this is fine, but it musnt hang.

Can you comment on this please?

I can supply the address of server where you can get this 75778 error, but if you need it please request this through email. I cannot post it here.
#1602
Posted: 10/28/2006 13:04:57
by Eugene Mayevski (EldoS Corp.)

1) HTTPS goes usually through the port 443, not 80. That's why you can't connect to https://gmail.google.com:80
2) allowed versions of SSL/TLS are specified using Versions property of the component. In Delphi the code looks like

Exclude(Versions, sbTLS11);

In C# it would be

Versions = Versions & (~SBConstants.Unit.sbTLS11)

Please check the help file for details.


Sincerely yours
Eugene Mayevski
#1607
Posted: 10/30/2006 03:30:27
by stephen kervin (Basic support level)
Joined: 10/27/2006
Posts: 5

Hi

1) Fair enough. Makes Sense.
2) As I mentioned above I have turned these off in Object Inspector. Turning it off in Object inspector should be the same as adding code? Even with them off, it still gives that error.

#1608
Posted: 10/30/2006 03:39:21
by Eugene Mayevski (EldoS Corp.)

1) Please provide the actual URL to test.
2) Are you using .NET or VCL or ActiveX edition?


Sincerely yours
Eugene Mayevski
#1611
Posted: 10/30/2006 04:36:33
by Eugene Mayevski (EldoS Corp.)

I can't connect to gmail.google.com:443 at all -- the TCP connection can't be established.


Sincerely yours
Eugene Mayevski
#1612
Posted: 10/30/2006 06:58:20
by stephen kervin (Basic support level)
Joined: 10/27/2006
Posts: 5

Quote
I can't connect to gmail.google.com:443 at all -- the TCP connection can't be established.


Yes, this is what I found. if you do not add a port of any kind it works i.e URL of https://gmail.gooogle.com
leave the port out

Quote
1) Please provide the actual URL to test.


I am allowed to publish this on an open forumn, can you please provide an email addresss to send this to.


Quote
2) Are you using .NET or VCL or ActiveX edition?


VCL
#1613
Posted: 10/30/2006 07:22:06
by Eugene Mayevski (EldoS Corp.)

You can use HelpDesk ( http://www.eldos.com/support/ticket_list.php ) for personal communications


Sincerely yours
Eugene Mayevski
Also by EldoS: CallbackDisk
Create virtual disks backed by memory or custom location, expose disk images as disks and more.

Reply

Statistics

Topic viewed 4670 times

Number of guests: 1, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!