EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Build 8.2.196 appears to have broken the SImple SFTP client

Also by EldoS: Rethync
The cross-platform framework that simplifies synchronizing data between mobile and desktop applications and servers and cloud storages
Posted: 03/16/2011 17:08:40
by Brett Beattie (Standard support level)
Joined: 03/08/2011
Posts: 25

OK, Using the SimpleSFTPClient from within my code and also when recompiling and running the SimpleSftpDemo_VS2008 project, the process hangs waiting on a response from the call to SftpClient.DownloadFile(). There is no error and no event raised after the first OnProgress event.

I get the same issue using
_SftpClient.DownloadStream(filename, memstrm, TSBSFTPFileTransferMode.ftmOverwrite);

I also get the same issue with SftpClient.UploadFile(dlg.FileName, remoteName);
All other calls seems to work fine (.ListDirectory, .RenameFile, .MakeDirectory, .RemoveFile)

I have tried with my key and also the demo default key.

When using the SophisticatedClient sample app it works fine.

Using build 8.2.196. for .net (c#)
Posted: 03/17/2011 00:47:14
by Eugene Mayevski (EldoS Corp.)

I can't confirm this. I have removed build 195 completely, downloaded and installed build 196 and successfully used SimpleSFTPDemo to upload and download a file to/from OpenSSH server and to/from Bitvise SSH server.

So the issue, while possible (due to the change made for buggy password manager pro), must be specific to some server software. OR it was a coincidence and your server software was updated at the same time so the problem is not with the build.

The symptoms indicate that you are having problem with the buggy server which doesn't handle pipelining right. This FAQ article describes the reasons and what to do in this case.

Sincerely yours
Eugene Mayevski
Posted: 03/17/2011 11:04:09
by Ken Ivanov (EldoS Corp.)

I have one guess though. Could you please check the value of TElSimpleSFTPClient.SocketTimeout property? If it is set to 0, could you please try setting it to e.g. 60000 and check if it changes something?
Posted: 03/17/2011 17:00:54
by Brett Beattie (Standard support level)
Joined: 03/08/2011
Posts: 25

Thanks I'll look into that today and let you know.
I had done testing against 2 different servers, one unix and one windows, different authentication and multiple different file types, so ruled out the server being the problem. I also saw the issue with clients on both my dev workstation and separate test server with only the assemblies in the runtime folder (not GAC'd).
(Remember it is only the TElSimpleSFTPClient that has an issue - the lower level classes used in the SophisticatedClient sample app worked fine).
Initially I thought I might have had my references crossed up between versions but I have re-done them a few times now.
Posted: 03/17/2011 17:20:16
by Brett Beattie (Standard support level)
Joined: 03/08/2011
Posts: 25

Good call Innokentiy. That setting does fix the problem.
Posted: 03/18/2011 00:18:47
by Eugene Mayevski (EldoS Corp.)

In any case, build 197 with several fixes is already on the site.
Upgrade is strongly recommended.

Sincerely yours
Eugene Mayevski
Also by EldoS: BizCrypto
Components for BizTalk® and SQL Server® Integration Services that let you securely store and transfer information in your business automation solutions.



Topic viewed 1440 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!