EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Visible digital signature not showing on PDF printout.

Posted: 12/09/2010 14:43:24
by SJVAPCD Programmers (Standard support level)
Joined: 06/14/2010
Posts: 9

I have a PDF document that has a visible stMDP signature on the first page and a stDocument signature on the last page. They are both visible when viewing the PDF in adobe reader but if printed on paper only the MDP signature prints out. The page containing the stDocument signature prints but does not print the signature. It does not show the signatuer in print preview either. Note that if I change both signatures to be of type stDocument then they both print fine. Any thoughts on what might be going on? See attached PDF.


[ Download ]
Posted: 12/09/2010 15:41:37
by Ken Ivanov (Team)

Thank you for contacting us.

Signature widgets can be either printable or non-printable; this property of a signature is defined by the signature author. Please adjust TElPDFSignature.WidgetProps.Print property when creating the signature to specify its printing behaviour.
Posted: 12/09/2010 16:06:20
by SJVAPCD Programmers (Standard support level)
Joined: 06/14/2010
Posts: 9

Thank you for the quick response.

Yes, I already have the WidgetProps.Print property set to true for both the MDP and Document signatures but the issue is still there.
Posted: 12/10/2010 00:43:25
by Eugene Mayevski (Team)

1) What version of Adobe Reader are you using?
2) Have you verified the signature before printing? The signature is not printed unless it's verified.

There were bugs in some versions of Adobe Reader related to printing signatures, and these bugs can't be solved on our side as these are namely Adobe's bugs.

Sincerely yours
Eugene Mayevski
Posted: 12/10/2010 12:18:32
by SJVAPCD Programmers (Standard support level)
Joined: 06/14/2010
Posts: 9


1) I tested this on Adobe Reader 6,7,8,9 and 10 with the same results.
2) Both signatures passed the validation check in Adobe without any errors.

I am able to consistently reproduce the issue by signing any random PDF document with 2 digital signatures using one to certify and the other to sign. Again, this doesn't happen when both are use to sign. I don't want to jump to the conclusion that Adobe Reader is the culprit yet. Do you have any suggestions as to an alternative of Adobe Reader or a known Adobe version that is known to work with your tools?

Note that I am using SecureBlackBox version 7.2.171. May I also note that in a similar post in the sense that the issue was in viewing rather than printing, Bogatskyy posted a sample certified/signed PDF responding to a fix in that particular post which seems to work. His sample PDF was certified and sign using two different signatures and both are printable when I printed it out. I find it very interesting that when I took his sample pdf and signed it using my signature, I run into the same issue. My signature shows up with the existing two when viewing but disappears when printed out. Could something may have changed in version 7.x to cause this? I also used the sample cert.pfx provided by SBB and signed the same file using the TinySigner project with a visible signature and the result was the same issue so I think it is my certificates.

The reference post was found [URL=https://www.eldos.com/forum/read.php?FID=7&TID=1561&MID=8645&sphrase_id=92938#message8645]Here[/URL]


Posted: 12/15/2010 16:16:51
by SJVAPCD Programmers (Standard support level)
Joined: 06/14/2010
Posts: 9

Any updates on this topic?

I did a test to see if the issue was related to my certificates. I used Adobe Acrobat Pro to create a PDF file with two empty signature fields. I then used Acrobat to certify and sign the PDF file using my certificates with the result that the file viewed and printed with both signatures. I then used SBB to certify and sign the PDF utilizing the empty signature fields and it too viewed and printed fine with only one issue. The second signature will invalidate the first if I set the IgnoreExistingAppearance to True. (Searched forum) Same bug that should have been fixed in this post. I updated to version 8 but still same bug just so you folks know. [URL=http://www.eldos.com/forum/read.php?FID=7&TID=1561&MID=8626&sphrase_id=97458#message8626]Here[/URL]

The last test I use SBB to certify the file either utilizing and or not utilizing one of the empty signature fields and then sign it not using one of the empty fields. This produced the issue. It seems like the issue lies within the signature widget of the signing certificate. If I tell SBB to add the signature then it creates the issue. If I tell SBB to use the empty signature field that I put in with Acrobat then all is well except for the existing validation bug as noted in the first paragraph.

Please let me know if you can confirm if it's a bug on your side and when it can be fixed. Try to certify any PDF and sign it with the widget set to visible and printable and print it out to confirm. Thanks.

Posted: 12/15/2010 16:38:16
by Ken Ivanov (Team)

Sorry for the delayed answer; we had to perform certain investigation concerning the topic.

The problem is indirectly caused by signature processing bug in Acrobat products up to version 9. Long ago we found out that any signature added to a certified document invalidates the certification unless its widget has some of the properties set to specific values. In particular, the Print property of the second signature must be set to False to preserve the validity of the certification. Therefore we had added a workaround that forcibly disables Print (and some other) flags of the second signature independently of the values assigned to them by user code; this excludes the possibility of accidental "corruption" of the certification by the components. I should stress that this bug only takes place for brand new signatures; signatures added to existing empty form fields do not invalidate the certification.

It appears that the problem has been fixed in Adobe Reader X. That's why we decided to add an option to allow user to turn off the mentioned workaround if no compatibility with older Acrobat products is needed. The code is being amended at the moment; the fix (not to say the workaround) will be available in the future SecureBlackbox build update.

Thank you for reporting the issue and sorry for making you wait for the fixes.



Topic viewed 27732 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!