EldoS | Feel safer!

Software components for data protection, secure storage and transfer

SBB Client Library-RDP

Posted: 10/25/2010 08:03:00
by Anu Azeez (Basic support level)
Joined: 10/25/2010
Posts: 3

We are evaluating SBB .NET Client library to develop a custom solution involving RDP. We are setting up Remote port forwarding tunnel, and using RDP on the source port. The RDP timesout/crashes after accepting the authentication credentials. This happens only when the destination is specefied to the same machine( Is this a known issue or do you have a solution to overcome this? We are using the Samples\C#\SSHBlackBox\Client\RemotePortForwding to test this.
Posted: 10/25/2010 09:08:02
by Vsevolod Ievgiienko (Team)


What is the address of your SSH server? or not?
Posted: 10/25/2010 17:44:32
by Sivakumar G Nair (Basic support level)
Joined: 10/22/2010
Posts: 5

To add to what issue Anu tried to explain earlier, we connect to an SSH server in our local network only. I am detailing things a bit here hoping to give you a better idea of what we have been doing:

I have been testing this with the following participating machines:

1. SSH server: IP -
2. Workstation 1 - IP -
3. Workstation 2 - IP -

Scenario A - I run the remote portforwarding sample from #2 box to setup a remote portforwarding to #2 itself - Fails everytime with repetitive tries to open/close secure channel status errors.

Scenario B- I run the sample from #2 to setup a remote port forwarding to #3 works eventhough it is very slow.

The solution we are trying to build using SSB.Net is Scenario A. Please let me know if you need more information/screen shots/sample code to describe the issue
Posted: 10/26/2010 02:56:47
by Vsevolod Ievgiienko (Team)

I need more information because RemotePortForwding sample works well in both Scenario A and B in my test network. I use OpenSSH server. What is your server software?
Posted: 10/26/2010 10:41:39
by Sivakumar G Nair (Basic support level)
Joined: 10/22/2010
Posts: 5

Yes we are using OpenSSH only. We used tools like Bitwise Tunnelier to setup remote portwarding and that works fine with Scenario A. If we try to use Putty instead of Tunnelier for Scenario A, it does not work and we are seeing similar behavior to your sample code.

I am attaching two screenshots here for yoor reference.

remportfwding_step1.png shows the initial SSH start session. The log list view tells you that the connection has been established.

remportfwding_step2.png Shows you the screenshot of the status when I RDP from to The RDP window comes up blacks out and hangs.

Please let me know if you need more specific information.
Posted: 10/27/2010 01:11:48
by Vsevolod Ievgiienko (Team)

I think you've forgotten to attach the screenshots.
Posted: 10/28/2010 04:04:13
by Anu Azeez (Basic support level)
Joined: 10/25/2010
Posts: 3

Here you go...

[ Download ]
Posted: 10/28/2010 05:15:31
by Vsevolod Ievgiienko (Team)

Do not use in the destination host field. This IP is reserved for localhost (http://en.wikipedia.org/wiki/Localhost). For Scenario A you should use instead of
Posted: 10/28/2010 11:25:40
by Sivakumar G Nair (Basic support level)
Joined: 10/22/2010
Posts: 5

We already tried to do this from Machine 1 and it did not work. Only IP that works from machine 1 is another machine IP. Can you please share the details on the scenarios you got it working. We tried this on both Win XP 32 bit and Win 7 64 bit and both giving same results. We are stuck with this for sometime now and are getting out of time in puting together a PoC. Any pointers in this regard would be of great help.
Posted: 10/29/2010 03:49:11
by Vsevolod Ievgiienko (Team)

Could you please check whether the same issue occurs with simple forwarding components SecureBlackbox.NET\Samples\C#\SSHBlackbox\Client\SimplePortForwarding. Unfortunately, the samples for sophisticated components are a bit outdated and may expose some side effects.



Topic viewed 3580 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!