EldoS | Feel safer!

Software components for data protection, secure storage and transfer

PDF Signing: No signing certificate found on Windows 2003

Also by EldoS: CallbackFilter
A component to monitor and control disk activity, track file and directory operations (create, read, write, rename etc.), alter file data, encrypt files, create virtual files.
#14331
Posted: 09/01/2010 02:29:07
by Peet Terluin (Standard support level)
Joined: 06/08/2007
Posts: 19

L.S.,

I made an application that signs a PDF using SBPDF.
On my development platform XP it works just fine.
Now I am testing on an windows 2003 machine and I get an
exception:
Quote
EElPDFPublicKeySecurityHandlerError
No signing certificate found

I've verified that the certificate store used contains a certificate with a private key and the certificate can be used for signing.

The windows 2003 machine does not have Adobe Acrobat installed.
I don't know if that matters, but it is just something that I noticed.

I hope you can help me with this.
With regards,
Peet Terluin
#14334
Posted: 09/01/2010 02:58:54
by Ken Ivanov (EldoS Corp.)

Thank you for contacting us.

Could you please check if TinySigner sample exposes the same issue?

The presence or absence of Acrobat on a particular machine does not matter.
#14337
Posted: 09/01/2010 04:09:21
by Peet Terluin (Standard support level)
Joined: 06/08/2007
Posts: 19

TinySigner works just fine ...
This will probably help me to locate and resolve the problem.
Thanks for your quick reply.

With regards,
Peet Terluin
#14364
Posted: 09/03/2010 07:48:51
by Peet Terluin (Standard support level)
Joined: 06/08/2007
Posts: 19

What went wrong:
I tried to make an in-memory copy of a certificate complete with its private key by SaveToStreamPFX followed by a LoadFromStreamPFX. When saving to stream Windows will ask for a password if the private key usage is password protected.
In this way the user only has to enter the password once.
However ... if the private key is not exportable ... it doesn't get exported.
So ... my copy-certificate did not contain a private key.
Problem solved.
Maybe the error message "No signing certificate found", but then again, now I know the problem.
#14365
Posted: 09/03/2010 08:06:31
by Ken Ivanov (EldoS Corp.)

We are glad that you have managed to resolve the issue. Thank you for publishing the result of your investigations here.

The component identifies signing certificates in the CertStorage store by the availability of the corresponding private keys (the store may also contain other, non-signing, certificates that will be simply included to the signature -- for chain verification purposes, for instance). That's why this very message is returned (== there is no certificates with private keys available, therefore there is no keys to sign with).
Also by EldoS: Solid File System
A virtual file system that offers a feature-rich storage for application documents and data with built-in compression and encryption.

Reply

Statistics

Topic viewed 2458 times

Number of guests: 1, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!