EldoS | Feel safer!

Software components for data protection, secure storage and transfer

SFTP Adapter: Connection lost (error code is 10058)

Also by EldoS: RawDisk
Access locked and protected files in Windows, read and write disks and partitions and more.
#11472
Posted: 10/26/2009 17:23:05
by CARLOS RAMIREZ (Basic support level)
Joined: 02/19/2009
Posts: 7

Hi,

We are using SFTP adapter from Biz Talk Server 2006 R2 to communicate with our vendor's SFTP server. While doing this, we get following error. Please advice.

Details:"Connection lost (error code is 10058)".

Regards
Ashish
#11475
Posted: 10/26/2009 17:50:10
by Ken Ivanov (EldoS Corp.)

Thank you for contacting us.

The error is usually thrown if the socket was forcibly closed by the remote side. Can you please provide us with the following information so that we could localize the issue:

1) does the error occur every time you are communicating with the server or from time to time,

2) does the error occur with some particular server or with some different servers,

3) please go to adapter configuration panel, set the Trace Level property to Debug, Trace to File to Yes, Trace to Event Log to No and provide a path to the log file via the Trace Filename property. Start the application and reproduce the issue, then post the created log file here (it is a good idea to use Helpdesk for posting log files to keep their privacy).
#11490
Posted: 10/27/2009 09:30:25
by CARLOS RAMIREZ (Basic support level)
Joined: 02/19/2009
Posts: 7

Thanks for your reply.

Please find the answers below.

1) does the error occur every time you are communicating with the server or from time to time,

A - Yes, it happens every time we try to send a file.

2) does the error occur with some particular server or with some different servers,

A - Unfortunately, our vendor has set up only one SFTP server. We do not have any other option. So I am sorry; cannot answer this question.

Also, please find the error log file attached.

Regards
Ashish


[ Download ]
#11492
Posted: 10/27/2009 09:59:13
by Eugene Mayevski (EldoS Corp.)

Thew log clearly says that authentication fails. You need to ensure that you have specified authentication-related properties correctly (i.e. you have chosen the right authentication method and provided corresponding authentication data, such as username or private key).

Note, that with any authentication method username must be set. If you use password or keyboard-interactive authentication, you need to specify the password.

If you use public-key authentication, you must specify your *private* (not public!!!) key, and the corresponding public key must be known to the server.


Sincerely yours
Eugene Mayevski

Reply

Statistics

Topic viewed 3458 times

Number of guests: 1, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!