EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Problems with TELHTTPSClient

Also by EldoS: BizCrypto
Components for BizTalk® and SQL Server® Integration Services that let you securely store and transfer information in your business automation solutions.
#10042
Posted: 05/18/2009 04:34:20
by Mihaela Mihaljevic Jakic (Standard support level)
Joined: 02/04/2009
Posts: 2

I'm posting data with:
rez := sslCli.Post(aGoogleContactsURL, aSL, '', '', nil, 'application/x-www-form-urlencoded', False);
the result is 200, which is ok.

My problems are:
1. I'm getting exception : Connection Lost
2. The data that is returned is messed up, I'm just seeing rectangles instead of characters).
I'm using Delphi 2009, and I did set {$Define SB_UNICODE_VCL}.

Please Help

Mihaela Mihaljevic Jakic
#10043
Posted: 05/18/2009 04:45:14
by Eugene Mayevski (Team)

1) The exception is handled internally. If you get the exception in IDE, you need to ignore it or put the exception to the list of ignored exceptions in IDE.
2) Please save your data to the text file and inspect it there using Notepad. Is it fine or broken?


Sincerely yours
Eugene Mayevski
#10044
Posted: 05/18/2009 05:16:18
by Mihaela Mihaljevic Jakic (Standard support level)
Joined: 02/04/2009
Posts: 2

Hi!

I've solved the issue 2. I just had to pass the stings as AnsiString and not String (Unicode), not it's OK.

Thanks.

Reply

Statistics

Topic viewed 1356 times

Number of guests: 1, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!