EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Error Uploading file to freeSSHD 1.2.1

Posted: 07/30/2008 22:13:00
by eric chaves (Basic support level)
Joined: 07/30/2008
Posts: 2

Hi Folks,

I'm evaluating SecureBlackBox and in order to test it I'm running a local sftp server named FreeSSHD version 1.2.1. When I try to upload a file with the SFTPConsole the call to Client.UploadFile (line 13) is made but the method never returns.

On the server side the file is created but it is never "filled" remaing always with zero bytes. With WinSCP I can transfer file to this server with no problem. Could tha be a problem of SBB with this particular server or am I missing something here?

My system is Windows XP SP2, Visual Studio 2005 and .NET framework 2.0. Both clients and server are running on the same machine.

Any help would appreciated.

Posted: 07/30/2008 23:41:38
by Eugene Mayevski (Team)

We don't support connecting to FreeSSHD due to bugginess of this server. Please use some more standard-compliant server, such as OpenSSH or some commercial solution.

Sincerely yours
Eugene Mayevski
Posted: 08/04/2008 11:41:59
by eric chaves (Basic support level)
Joined: 07/30/2008
Posts: 2

Hi Eugene,

Thanks for the answer. I'm trying to setup the SFTP server with OpenSSH as you suggested but I'm having a real hard time to make it work. I know this is totally off-topic and out of Eldos scope, but I was wondering if you guys have some documents or links on the internet that may help me in the process of setting up this server.

I trying to use sshwindows, an build of OpenSSH for windows, and the SSH server is working fine but the SFTP does not get initialized and I can't figure out what could be wrong.

Could you point me something (apart from OpenSSH site, off course) that may help me out?

thanks in advance.
Posted: 08/04/2008 13:37:07
by Eugene Mayevski (Team)

SSHWindows is discontinued. Grab CopSSH instead. This is the supported port of OpenSSH.

Next, check sshd_config . It must contain the following line:

# override default of no subsystems
Subsystem sftp /usr/sbin/sftp-server

And you should have "sftp-server.exe" in <virtual root>\usr\sbin folder.

Sincerely yours
Eugene Mayevski



Topic viewed 1519 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!