EldoS | Feel safer!

Software components for data protection, secure storage and transfer

SBB 6 IOHandler10 trouble

Also by EldoS: CallbackDisk
Create virtual disks backed by memory or custom location, expose disk images as disks and more.
Posted: 07/04/2008 14:47:39
by Kevin Donn (Standard support level)
Joined: 08/16/2007
Posts: 20

I had gotten pretty comfortable with the Indy10 SSL IOHandler support in SBB 5. I had gotten both the client and server demos going, and had written my own simple apps that loaded my own certs and everything was working fine. I decided I needed to go ahead and upgrade to SBB 6 today. The upgrade went smoothly and my production application seems to work fine.

However, I'm no longer able to get any of the Indy10 SSL IOHandler stuff to work. I've gone back to just trying to get the demos to work and I'm not having any luck with SSLBlackbox\Server\Indy\IOHandler10 demo. I just get an error with IE. When I try to connect with the SSLBlackbox\Client\Indy\IOHandler10 demo I simply get "Error connecting with SSL." No error code or anything.

Any ideas?

Kevin Donn
Posted: 07/06/2008 05:42:17
by Scratch  (Standard support level)
Joined: 02/07/2008
Posts: 34

Try to set ConnectTimeout and ReadTimeout to -2 in both Server and IOHandler. That works for me (at last).
Posted: 07/07/2008 18:05:41
by Kevin Donn (Standard support level)
Joined: 08/16/2007
Posts: 20

Yep, that works. Just for the record, just setting ConnectTimeout to -2 worked as well for me.





Topic viewed 1018 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!