EldoS | Feel safer!

Software components for data protection, secure storage and transfer

GetProcessName not working

Also by EldoS: RawDisk
Access locked and protected files in Windows, read and write disks and partitions and more.
#32646
Posted: 03/17/2015 16:16:53
by umair sadiq (Basic support level)
Joined: 01/23/2015
Posts: 7

A call to CallbackProcess.GetProcessName returns error code 122 and the message "The data area passed to a system call is too small".

I have tried passing buffers of 2k and 20k as well, but it still returns the same error. The value of 'ResultLength' also does not change.

This is for the C++ lib. Is there any pre-requisite to make this call successfully?

Thanks.
#32649
Posted: 03/18/2015 02:45:39
by Volodymyr Zinin (EldoS Corp.)

Thank you for the report. I have reproduced the problem too. There is a bug in this method and it will be fixed in the nearest build.

Reply

Statistics

Topic viewed 3075 times

Number of guests: 1, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!