EldoS | Feel safer!

Software components for data protection, secure storage and transfer

big size disk format problem

Posted: 03/07/2013 03:36:27
by SystemAdmin  (Basic support level)
Joined: 03/07/2013
Posts: 4

Hello there,

My system is win7 pro 64 bit, C builder embercado 2010. I used a demo of callback disk product. Demo is creating a large-capacity disk fails. Ceateing success but not formatting. (40 GB). I can try another OS. XP 32 bit vs. but not success. Can i e create and format a large capacity disk using callbackdisk?

Best regards
Posted: 03/07/2013 03:38:27
by Eugene Mayevski (Team)

The sample doesn't format the storage. It creates an unformatted disk which you can format to FAT or NTFS.

Sincerely yours
Eugene Mayevski
Posted: 03/07/2013 03:41:23
by SystemAdmin  (Basic support level)
Joined: 03/07/2013
Posts: 4

Hello Mayevski,
I tried on my computer (NTFS file system), but did not succeed.
Posted: 03/07/2013 03:42:44
by Eugene Mayevski (Team)

"It didn't work" is not something we can help with. Please provide detailed description of the problem.

Sincerely yours
Eugene Mayevski
Posted: 03/07/2013 04:01:13
by SystemAdmin  (Basic support level)
Joined: 03/07/2013
Posts: 4

Hello Mr. Mayevski,

I am building a 40 GB virtual disk using callback disk. The result is successful. However, this virtual disk with the windows formatting "format process did not finish" message appears, and not format the virtual disk.

Best regards,

Posted: 03/07/2013 04:29:18
by Eugene Mayevski (Team)

1) What is the exact size of the file you are creating? Try making it a multiple of 65536 (64 Kb).

2) the message unfortunately doesn't give much information. Try to use "format" command from command line - maybe it can provide more meaningful message.

Sincerely yours
Eugene Mayevski
Posted: 03/07/2013 05:20:33
by Volodymyr Zinin (Team)

Also please specify the version of CallbackDisk you are using. If it isn't the latest one then check the problem with it.
Posted: 03/14/2013 03:04:50
by SystemAdmin  (Basic support level)
Joined: 03/07/2013
Posts: 4

i tried your directions.

Component settings:

CBDisk1->SectorSize=512; //1024,2048,4096 tried . 8192 disk not created

callbackdisk version 2.1.86
Driver version

attachment is command prompt format command result.

Finally problem is still continue.

Posted: 03/14/2013 03:37:53
by John Hanley (Standard support level)
Joined: 07/01/2010
Posts: 3


Are you trying to use a sector size of 8192 bytes?

This is not supported under Windows. Valid sector sizes are 512, 1024, 2048 and 4086.

Any sector size larger than 512 is "big sectors" or "large sectors".

I don't remember which versions of Windows that support "big sectors" so unless you are trying to create a virtual disk exceeding 2 TB, stay with 512 byte sectors.
Posted: 03/14/2013 04:00:11
by Volodymyr Zinin (Team)

There is already 3.0.91 version. So it's better to use it.
And instead of CBDisk1->StorageCharacteristics=scRemoteDevice;
try to use CBDisk1->StorageCharacteristics=scRemovableMedia;



Topic viewed 12809 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!